Troubleshooting
Problem
This technote explains why the error []db_VISTA database error -910 - key file inconsistency[] may appear in the logs when using IBM® Rational® ClearCase® and provides information on how to troubleshoot the problem.
Symptom
Errors like the following are reported in the db_server logs
2008-04-16T16:45:39-05 db_server(17221): Ok:
2008-04-16T16:45:39-05 db_server(17221): Ok: *** db_VISTA database error -910 - key file inconsistency
2008-04-16T16:45:39-05 db_server(17221): Ok: DBMS error in "../db__err.c" line 321
2008-04-16T16:45:39-05 db_server(17221): Error: DBMS error in /abc/vobstore/thirdParty.vbs/db.
Cause
The errors may be caused by a corruption in the VOB database identified in the error message (VOB thirdparty.vbs in the above example).
Diagnosing The Problem
If you run a dbcheck you may also see errors like the following reported:
dbcheck error:
*** db_VISTA database error -910 - key file inconsistency
Problems at record 1598:
* key field EVENT_KEY4(94) error: has a missing key
Resolving The Problem
Further analysis of the VOB database will have to be performed to determine the full extent of the problem.
You should contact IBM Rational Client Support for assistance and be prepared to provide the information detailed in the following technote.
Technote 1122499 MustGather: Data collection for possible VOB database corruption
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21315385