IBM Support

b\ error description = (null) error, during an e-mail notification attempt

Troubleshooting


Problem

This technote identifies an IBM® Rational® ClearQuest® defect relating to E-Mail Notification that can cause an error to occur when submitting or changing records.

Symptom

When submitting, modifying, or changing the state of a record that triggers an E-mail Notification, an error message similar to this might occur:

Execution of a hook failed during the action Submit. It was the ACTION_NOTIFICATION hook attached to the Defect "SAMPL00000001". The reason for the failure was:


Error processing Email Rule "New Submissions" : "b\    error description = (null)"

Cause

This issue was identified as a product defect under APAR PK69344. Beyond this defect, these causes have also been identified:

  • MAPI is used for E-mail Notification. CDO is not installed.
  • The SMTP server in the E-Mail options screen is incorrect.
  • The E-mail address in the E-mail options is incomplete. For example, you might have an invalid domain name defined in the address.
  • The E-mail address in the E-mail options has a domain that is blocked by the mail server.

Environment

This problem has been observed when clients are using MAPI and SMTP as a protocol for E-mail notifications.

Diagnosing The Problem

For SMTP servers, run this command:

telnet <SMTP_host_name> 25


You should receive similar output that indicates successful connection information:

220 SMTP_host_name ESMTP Sendmail 8.14.3/8.13.1/NCO v10.0 AVin; Thu, 15 Apr 2010 19:09:23 -0400


If not, you are unable to connect to that server. You must resolve what the network is not letting you establish this connection.
  • To determine if this is a DNS issue, try using the SMTP server IP address instead of the host name in the ClearQuest Email options.
  • Investigate if port 25 is blocked.

Resolving The Problem

If using MAPI, verify that CDO is installed on the client workstation and configured correctly. Technote 1128793 has more information on checking for CDO installation. Also make sure that the correct server and E-mail address is defined in the E-mail options screen if using SMTP.


Note: This error has also been reported to have been resolved by removing, then recreating all e-mail rules.

Related Information

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"E-Mail Configuration and Setup","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21314404