IBM Support

"Your Rhapsody installation does not include the Rhapsody Model Manager add-on" error when opening an RMM model.

Troubleshooting


Problem

 You attempt to open a model in the IBM Engineering Systems Design Rhapsody client that has Rhapsody Model Manager profile added to it and get the error "Your Rhapsody installation does not include the Rhapsody Model Manager add-on"

Cause

When an RMM-enabled model is opened in the Rhapsody client, it checks the rhapsody.ini file for the presence of the ManagementMode=RMM line in the [General] section of the .ini. If the entry is not found, the error message is displayed and the model is not opened.

Diagnosing The Problem

Check that Rhapsody Model Manager feature installed:
1) Open the Windows Control Panel
2) Launch Programs and Features. 
3) Select Rhapsody in the list of installed programs.
4) Click the Change button.
5) When the Rhapsody installer starts, click Next and select the Modify radio button.
6) Click Next and verify that the Rhapsody Model Manager feature is present.
Check that the ManagementMode=RMM line is present in the rhapsody.ini file. If the line is missing, add it. Also, check to make sure there is only one rhapsody.ini file on the computer. If there is a rhapsody.ini file in the C:\Windows directory, for example, Rhapsody might be loading this .ini file (which could have the line missing) instead of the expected .ini file.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSB2MU","label":"IBM Engineering Systems Design Rhapsody"},"ARM Category":[{"code":"a8m50000000Cjc8AAC","label":"Rhapsody->Model Manager->Rhapsody Client"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
27 May 2022

UID

ibm16202514