Troubleshooting
Problem
This document describes how to fix the following error when testing a data source connection to Salesforce:
XQE-GEN-0002 An unexpected exception occurred: Connecting "test.email@ibm.com@https://test.salesforce.com:443/services/Soap/u/20.0" failed. Error message "org.apache.axis2.AxisFault: Permission denied: connect" .
Cause
This issue occurs when Cognos is unable to reach the Salesforce server.
Resolving The Problem
Ensure the port 443 used for HTTPS is not blocked for outbound calls on the server where the Dispatcher component is installed.
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
25 February 2019
UID
ibm10872414