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Work orders do not show up in the Maximo Mobile 8.x Technician application

Troubleshooting


Problem

Why can't we get the work orders to show up in the Maximo Mobile Technician application using the "Assigned work" query? 

Symptom

Database error: SQLCODE=-104 error.

Cause

A closer look into the Maximo logs reveals that the below query runs when going to the work order list screen in the app:

app (null) object (WORKORDER) : select * from workorder where location= 'xxxxx' and siteid= 'xxxxx' and istask=0 and status in (select value from synonymdomain where domainid ='WOSTATUS' and maxvalue not in ('CAN')) order by statusdate desc order by statusdate desc for read only

Something is obviously wrong with the ending of that query, at the end it repeats itself, which causes an SQLCODE=-104 error.

Environment

Tivoli's process automation engine 8.3.0
IBM Maximo Application Framework 8.7.0
IBM Maximo Anywhere 8.0.1
IBM Maximo Manage 8.3.1

Diagnosing The Problem

This is related to a change made in newer Manage environments.
There is a WOBYASSET query on the asset table and a similar query (WOBYLOCATIONS) on locations used to retrieve work orders in that same location/ with the same asset. 

Resolving The Problem

This "order by" in the query itself causes issues with repair facilities so we changed how the API request was built to fix it.
The query is updated in 7.6.1.X environments but wasn't fixed in MAS environments.
Just remove the "order by" on those queries and it will resolve the issue. 

Document Location

Worldwide

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Document Information

Modified date:
16 January 2023

UID

ibm16606313