Question & Answer
Question
WMS: StartReceipt action displays error "YFS10533 : Invalid Shipment". Why?
Answer
During start receipt system throws the following error:
YFS10533 :
Invalid Shipment. [UniqueExceptionId='01001001001012495368735500000000000008']
[ApiName : startReceipt, ElementCount : 1, UserId : , ProgId : Console]
com.yantra.yfc.util.YFCException at
com.yantra.omp.business.receipts.YFSManageReceipt.createManualShipmentForReceipt
(YFSManageReceipt.java:116) at
com.yantra.omp.business.receipts.YFSManageReceipt.handleCreateReceipt(YFSManageR
eceipt.java:81) at
com.yantra.omp.business.receipts.YFSManageReceipt.createReceipt(YFSManageReceipt
.java:68) at
com.yantra.omp.business.receipts.YFSSuperReceiptManager.getReceiptHeader(YFSSupe
rReceiptManager.java:1067) at
com.yantra.omp.business.receipts.YFSSuperReceiptManager.getReceiptHeader(YFSSupe
rReceiptManager.java:1042) at
com.yantra.omp.business.receipts.YFSChangeReceipt.handleChangeReceipt(YFSChangeR
eceipt.java:102) at
com.yantra.omp.business.receipts.YFSChangeReceipt.changeReceipt(YFSChangeReceipt
.java:80)...contd.
Root cause:
Shipment for which user is
trying to start the receipt might still be in shipment created status.
On inbound shipment creation, shipment should be confirmed.
Once
shipment moves to shipment shipped, then the receipt can be started.
This
behavior is driven by the InboundShipment and InboundReceipt pipelines.
Resolution:
If the shipment is observed to be in Shipment
created status, confirm the shipment so that it moves the shipment status to
shipment shipped from shipment created.
This will allow the shipment to
be initiated for receipt using the startReceipt action.
Historical Number
FAQ3119
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Document Information
Modified date:
16 June 2018
UID
swg21520011