IBM Support

"Windows cannot open the folder" error when trying to open or extract one of the BPMN 2.0 compressed/zip files

Troubleshooting


Problem

After having installed one of the 8.5 Industry Models SOA offerings (e.g. IBM Banking Process and Service) and when trying to open or extract one of the BPMN 2.0 compressed/zip files (e.g. BPS85_APM_BPMN20.zip), the following error appears ""Windows cannot open the folder. The Compressed (zipped) Folder is invalid."

Cause

The issue is caused by the fact that extracting the file would create paths that are deeper than the Windows MAX_PATH characters allowed.

Diagnosing The Problem


1. Trying to open the BPS85_APM_BPMN20.zip or IPS85_APM_BPMN20.zip file or trying to extract it using the Windows context menu triggers the following message:


2. Using an alternative utility to the native Windows Compressed (zipped) Folders Extraction Wizard to extract the same files might trigger the following message:

Resolving The Problem

In order to resolve this problem:

1. Copy and paste the zip file into a higher directory level (e.g. C:\temp)

2. Use an alternative utility to the native Windows Compressed (zipped) Folders Extraction Wizard to open the file or perform the extract operation

[{"Product":{"code":"SSRA3Z","label":"IBM Banking Process and Service Models"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSRASJ","label":"IBM Insurance Process and Service Models"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.0","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
16 June 2018

UID

swg21641477