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Why are Refund fulfillment orders with incorrect amounts being generated when dynamic charge transaction is enabled?

Troubleshooting


Problem

When dynamic charge transaction is enabled and multiple payment methods (like gift card and credit card) are being used on an order, refund fulfillment orders for incorrect amounts are being generated.

Cause

This is because the sum of authorizations is greater than the order total, due to which the charge mapping is occurring incorrectly

Diagnosing The Problem

When using manageChargeTransactionRequest to create ChargeTransactionRequests, these requests should be updated whenever they are based on changes. For example, if the business process is to create a Charge Transaction Request for each release.If a release has a line canceled, then the request that represents the cancellation should have its MaxRequestAmount reduced to the new total. This will finally lead to the invoice total which gets mapped to the CTR.

In addition, the Refund Fulfillment Order is being split into multiple orders due to the flag - "Allow immediate Refund from hold amount" being enabled.

Resolving The Problem

In order to resolve the issue -
1. Ensure that the total authorizations created is not more than the order total.
2. The flag - Allow immediate Refund from hold amount should be disabled

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Document Information

Modified date:
16 June 2018

UID

swg22015634