Troubleshooting
Problem
When orders with BillToID are being imported using importOrder API, the API makes a call to getCustomerDetailsUE (if enabled) to get the customer details. If the details are not retrieved, the API fails to import the order. When legacy orders are being imported into the system, the customer details may not be present
Cause
The reported observation is the current behavior of the application.
There are minimal validations that are in place in the API to keep the system and data consistent for future processing.
Diagnosing The Problem
When the BillToID is passed in the order , the application expects this to be a valid ID.
Resolving The Problem
The following options can be considered -
1. Explore the option of removing the BillToID in the orders being imported.
2. Explore the option of suppressing the call to the external system in the UE for orders where the customer data is not present
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Document Information
Modified date:
16 June 2018
UID
swg22014200