IBM Support

What are the .nfs files that accumulate and why can't they be deleted even after stopping Cognos 8?

Troubleshooting


Problem

What are the .nfs files that accumulate and why can't they be deleted even after stopping Cognos?

Cause

Under UNIX, if you remove a file that a currently running process still has open, the file isn't really removed. Once the process closes the file, the OS then removes the file handle and frees up the disk blocks. This process is complicated slightly when the file that is open and removed is on an NFS mounted filesystem. Since the process that has the file open is running on one machine, and the files are on the server, there has to be some way for the two machines to communicate information about this file.

The way NFS does this is with the .nfsNNNN files. If you try to remove one of these file, and the file is still open, it will just reappear with a different number. So, in order to remove the file completely you must kill the process that has it open. Once you have located and killed the process that has the file open, the .nfs file will go away automatically.

Put another way, the .nfsxxxx files are used by NFS clients to manage the deletion of open files. If an open file is deleted, then the client renames it to .nfsxxxx. If the last open to this file is closed then the client should send a request to remove it. However, if the client crashes before it can clean up then you'll be left with these files.

Environment

UNIX (Solaris, AIX, HPUX)

Resolving The Problem

The root should have a cron job to clean up these leftover files.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF027","label":"Solaris"}],"Version":"10.2;10.2.1;10.2.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1026564

Document Information

Modified date:
15 June 2018

UID

swg21340934