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Web Service: No response received after dynamic service

Troubleshooting


Problem

Customer creates a web service client in Sterling B2B Integrator. The dynamic service is created during check-in without any error. The Dynamic Service, which is included in the client BP, runs without a error. But no response is available after the call of the dynamic service.

Symptom

No error reported. No response received from web service provider

Cause

During check-in of the WSDL the customer chooses "Other Transport (HTTP/HTTPS). So the dynamic service only creates the soap message. The transport level is not part of the dynamic service actions.

Environment

Sterling B2B Integrator > 5.2.5_2

Diagnosing The Problem

In Sterling B2B integrator GUI:
1) Deployment->Web services->WSDL check In: Search for the WSDL
2) Click on Source Manager
3) Click on Edit

Verify that " Other Transport (HTTP/HTTPS) " is selected.

Resolving The Problem

This is working as designed.

For "Other Transport (HTTP/HTTPS) the dynamic service only creates the soap message. You need to add SOA Outbound Message Processing Service, HTTP Client Begin, HTTP Client POST and HTTP Client End service in your BP after the dynamic service.

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Document Information

Modified date:
26 November 2019

UID

swg21993932