Troubleshooting
Problem
In Planning Analytics Workspace, when changing a particular Exploration View to a visualization (synonyms: graph, or chart)
The following error is displayed:
We can't load the visualization, because its associated data set 'undefined' isn't available
Cause
Unknown, but the assumption is there are several possible causes:
-This might be due to a defect in the visualization.
-This might be due to a lack of features in a particular type of visualization. For example, an unknown town in the provided Atlas container.
-This can be due to corrupted or old temporary files in Websphere Liberty Profile, for some of the containers. For example, a recent upgrade might have left these old files behind, which cannot work with the new version of Workspace.
Resolving The Problem
If the version of Planning Analytics Workspace is too old, it is recommended to upgrade to a more recent version first.
Once done, re-create the containers in order to get rid of any old temporary files in Websphere Liberty Profile (several containers are using their own WLP application server).
A simple restart of the containers by using "stop/start" or "restart" command-lines is not sufficient.
Here are the necessary steps to properly regenerate the containers (note: on Windows, these actions do not touch the existing databases and images):
cd <PAW_root_path>
./scripts/paw.ps1 stop
docker rm $(docker ps -a -q)
./scripts/paw.ps1
Don't use any command-line parameters in the last command.
Wait one or two minutes then display the container states by using this command:
/scripts/paw.ps1 ps
Once bss-init and couchdb_init containers are in "Exit" state while all other containers are "Up", then the Planning Analytics Workspace is available again. Reconnect and verify whether the issue is solved.
Document Location
Worldwide
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Document Information
Modified date:
07 October 2021
UID
ibm16497173