Troubleshooting
Problem
Attempts to login to Application console leads to the error Could not find entity in IBM Sterling Order Management.
Symptom
The complete error message is:
<Error ErrorCode="0"
ErrorDescription="Could not find entity ( probably changed
lockid) [ SELECT
YFS_ORGANIZATION.CREATEPROGID,YFS_ORGANIZATION.CREATEUSERID,YFS_ORGANIZA
TION.MODIFYUSERID,YFS_ORGANIZATION.MODIFYPROGID,YFS_ORGANIZATION.CREATET
S,YFS_ORGANIZATION.MODIFYTS,YFS_ORGANIZATION.ORGANIZATION_KEY,YFS_ORGANI
ZATION.LOCKID
FROM YFS_ORGANIZATION YFS_ORGANIZATION WHERE
YFS_ORGANIZATION.LOCKID=? AND YFS_ORGANIZATION.ORGANIZATION_KEY=? ]"
ErrorRelatedMoreInfo=""
ErrorUniqueExceptionId="10.1.10.17814600137439820000000081687">
Cause
Issue was caused due to cache refresh was not happening due to RMI connectivity issue.
Diagnosing The Problem
Warehouse users are not able to login to sterling application console. IT team is able to login from the system where as the users in warehouse are not able to login into the system with below errors seen in logs.
The server logs records the connection errors
java.net.ConnectException: Connection refused [admin]: YFCRemoteUtils
[4/20/16 13:09:10:344 IST] 000000bd SystemOut O 2016-04-20 13:09:10,344:ERRORDTL:WebContainer : 0: [1461137950343]java.rmi.ConnectException: Connection refused to host: 127.0.0.1; nested exception is:
Resolving The Problem
To resolve the RMI connectivity issue, add the system property java.rmi.server.hostname with hostname.
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Document Information
Modified date:
16 June 2018
UID
swg21989022