Troubleshooting
Problem
When using the IBM Rational DOORS client users do not see anything in their favorites list or they are seeing older entries.
Symptom
DOORS Client users report a loss of their in-application favorites, either manifesting itself in an empty favorites list or the reversion to a considerably older version of the favorites list.
Cause
When a user updates their list of favorites (bookmarks) in the DOORS client but the write back of the favorite list is not completed properly / not valid, DOORS client will present an empty favorites list / an old favorites list upon next DOORS client launch.
Environment
Any currently supported DOORS Client Version 9.x on Windows, any currently supported DOORS Server 9.x on Windows or Linux.
Diagnosing The Problem
If the symptom is presented, confirm if the user sees an empty or an old list of favorites.
If the list is empty, the file on the DOORS Server data folder containing this specific user's favorites list is missing. There was probably an interruption of the DOORS client bidirectional server connection, the last time the user updated their favorites in the DOORS Client.
If the list appears to contain entries from many months or years ago, the current list of favorites is missing but a previous list was found in the database from an older version of DOORS. The reason this list is retrieved and used in the DOORS client is for continuity reasons during migration of environments from older DOORS versions to currently supported versions.
Multiple users reporting the same problem around the same time from the same location may indicate general connection problems that affected an entire subgroup of the DOORS user population. There is a chance, that the data they modified during that time will be affected. Run an Integrity Check against the potentially affected projects / folders or the entire DOORS database.
All users reporting this issue in combination with other data corruption reports may point towards a general failure on the system / storage device hosting the DOORS database. Consult your server administrators to discuss the status of the storage system hosting the DOORS database.
Resolving The Problem
With the favorites list for a particular user missing or outdated the first step is to identify the exact location of the relevant file in the DOORS database file system structure.
- You will need DXL powers in DOORS and access to the DOORS data folder in order to run this analysis.
- Once you identified the current favorites file, you can ask your server administrators to restore the corresponding file from the backups immediately prior to the loss of the favorites.
- You can also use the steps below to view and confirm the file in the backup archive contains the favorites your user is missing. If it doesn't, then restoring it will be of no value.
- Shutdown the DOORS server as you cannot replace any files on your DOORS database. You may need to wait for a maintenance window to do that.
- If your user has stored new favorites in the meanwhile, restoring the backup will overwrite these changes. They may want to make a note of their new favorites and add them once everything is back in order again.
The details for each user (if they have saved any items to Favorites)are saved in the
"DOORS DB Server data directory\conf"
directory. Also for each user, a unique folder would be created within the
conf
folder within which the details would be stored. Hence, if you want to identify favorites for a specific user, you would have to first identify the unique id of that user and then find out the corresponding folder in the conf directory.
Note: Its recommended that you ONLY use this for reading information and NOT do any manual modifications as this may lead to corruption of user related information.
- Identify the unique ID of a specific user:
- Log in as Administrator account in DOORS
- Edit the DXL from the DB Explorer Tools > Edit DXL
- Copy paste this code and replace the name
TEST
with their affected user's username value:
User u = find "TEST"
string s = u.identifier
print s
This would produce an output similar to "0000000000000002" depending on the id assigned to that user.
- Identifying the corresponding user folder in
conf
directory - Log in to the machine where the DOORS DB Server data directory resides
- Navigate to the data directory "
conf
" folder.
(example: C:\Program Files (x86)\IBM\Rational\DOORS\9.6\data\conf
) - In the
conf
folder, you will notice a file nameduserdirs.idx
" - Open the file in a text editor. For example notepad
NOTE: Make sure that there are NO manual modifications done in this file and the contents are only viewed and nothing should be changed. - Search for the value that you had got by running the DXL in step 1. (in our example: 0000000000000002).
You will notice that there would be a entry named similar to "u1000003.dir
" when the unique ID is searched.
This is the name of the folder which resides in the conf directory and corresponds to the user which had been searched in DOORS. - Close the file.
- Navigate to the
.dir
folder identified as above ("u1000003.dir" in our example) and within which there should be a text file named
"favorites+AF8-ext.txt".
- Close the file.
NOTE: Make sure that there are NO manual modifications done in this file and the contents are only viewed and nothing should be changed.
Be sure to shutdown the DOORS server before replacing ANY files in the DOORS Server Data Folder!
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Document Information
Modified date:
01 May 2020
UID
swg22011315