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Users are not logged out of ELM applications after the LTPA timeout period is reached

Troubleshooting


Problem

When the IBM Lightweight Third Party Authentication (LTPA) timeout value is set on the application server you use (WebSphere® Application Server or WebSphere Application Server Liberty Profile), the Jazz Team Server does not log out users after the timeout period is reached.

Symptom

Users can continue working in the web UI of the ELM applications after the LTPA timeout period is reached.
Users are not redirected to the login page.

Cause

The OAuth access token keeps users logged in.
Note: Inconsistent LTPA timeouts and OAuth access token timeouts can also lead to other issues such as missing links in Export to CSV output when using the RM application.

Resolving The Problem

The LTPA timeout value that is set for the application server you use (WebSphere® Application Server or WebSphere Application Server Liberty Profile) must match the OAuth access token timeout property value that is set in the Jazz Team Server and other ELM applications.
If other applications are registered to a different Jazz Team Server, and these applications also contribute functionality such as links to the applications registered to the first Jazz Team Server, then all the timeout values should be equal.

Refer to Configuring authentication session timeout  for instructions how to set the value.

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Product Synonym

Rational Collaborative Lifecycle Management Solution

Document Information

Modified date:
28 April 2021

UID

swg21701088