Troubleshooting
Problem
User is automatically removed from the MAXADMIN security group, and other default security groups defined in the system properties for IBM Maximo Predict and Health and Predict - Utilities (HPU) when a user synchronization occurs. This happens when Predict and HPU are installed and the user is not given access permissions in Maximo Application Suite.
Note:Other Maximo Application Suite applications may face the same permission behavior for this scenario, including Mobile applications. (Civil, Inspections, Technician, etc)
Detailed information
When user synchronization happens from Maximo Application Suite to Maximo Manage:
IF
Maximo Application Suite instance has Predict and HPU installed;
AND
Permission to these apps is marked as NOACCESS on Maximo Application Suite;
AND
User is assigned to MAXADMIN or the groups defined in system properties mxe.defaultgroups.predict.admin or mxe.defaultgroups.hputilities.admin;
THEN
User is removed automatically from those groups when the user synchronization task runs.
IF
Maximo Application Suite instance has Predict and HPU installed;
AND
Permission to these apps is marked as NOACCESS on Maximo Application Suite;
AND
User is assigned to MAXADMIN or the groups defined in system properties mxe.defaultgroups.predict.admin or mxe.defaultgroups.hputilities.admin;
THEN
User is removed automatically from those groups when the user synchronization task runs.
Symptom
User gets removed from the MAXADMIN security group when a user synchronization takes place and loses permissions to certain applications they might have had access to prior to the user synchronization.
Cause
Code for user synchronization in this scenario must be updated to resolve the issue.
Environment
Manage 8.5, Manage 8.6 (With Health and Predict installed in the environment)
Diagnosing The Problem
If you have Maximo Manage with Health, Predict and HPU installed in your Maximo Application Suite environment, and a user synchronization occurs, you can see this issue if Predict and HPU are assigned "No Access" permissions in Maximo Application Suite.
Resolving The Problem
Workaround: Create a new security group instead of using the MAXADMIN group for your user(s), or the default groups defined in Maximo Manage system properties. This issue has a planned resolution in Maximo Application Suite 8.11 / Maximo Manage 8.7 release.
Document Location
Worldwide
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Document Information
Modified date:
28 March 2023
UID
ibm16964002