General Page
The following tasks provide an upgrade path from any version V8.0.1 and later to any later version. You can upgrade from Taskmaster version V8.0.1 or V8.1 to any Datacap V9.x version. You can upgrade from any Datacap V9.x version to any later Datacap V9.x version.
Before you begin
- Review the Software Product Compatibility Reports for supported operating systems, related software, and hardware.
- Complete all Datacap batches.
- Close all Taskmaster client applications.
- Stop the Datacap Server service, Web services, Rulerunner services, Fingerprint services, and Maintenance (NENU) services.
- Back up existing objects to a temporary location:
- Administration, Engine, and Fingerprint database tables
- Custom applications (including any standard applications that you modified)
- Custom actions
- RuleRunner configuration files (RuleRunner.xml)
- The datacap.xml file
About this task
The following tasks provide an upgrade path from any version V8.0.1 and later to any later version. You can upgrade from Taskmaster version V8.0.1 or V8.1 to any Datacap V9.x version. You can upgrade from any Datacap V9.x version to any later Datacap V9.x version.
The starting version and ending version can include fix packs but do not require that fix packs are applied.
Test the new Datacap system in a test environment. When you are satisfied with the performance of the test environment, make the test environment your production environment.
Install the target version of Datacap
About this task
Procedure
Configure the environment
Procedure
Upgrade database schemas
About this task
- Db2®, Oracle, and SQL databases
- Databases schemas are upgraded in V9.0.1, V9.1.5, and V9.1.7. If your upgrade crosses one of those versions, you must upgrade to database schemas that are compatible with the new version of Datacap. If your upgrade does not cross any of those versions, no database upgrade is required.
You can upgrade old Db2, Oracle, or SQL databases to be compatible with the new version of Datacap. Datacap provides scripts that upgrade the schemas of existing databases. For more information, see Upgrading Db2, Oracle, or SQL databases for Datacap applications.
- Microsoft Access databases
-
From V9.0 onward, Datacap provides Microsoft Access databases that contain appropriate schemas for each Datacap version. The Access databases support the Datacap standard, non-customized applications. For standard applications, no database upgrade is required.
For customized applications, you must add your database customizations to a database that is compatible with the new Datacap version. For more information, see Upgrading Microsoft Access databases for customized Datacap applications.
Upgrade Datacap applications
Procedure
Upgrade customized screen panels
Procedure
- If your version before migration is V9.0.0 or later, complete the following task:
Rebuild Datacap Desktop customized screen panels by using the Datacap Developer Kit (DDK) for the target product version. In some cases code modifications are required.
- If your version before migration is V8.1 or earlier and your target version is V9.0.0 or later, complete the following task:
Datacap V9.0.0 and later requires Datacap Desktop screen panels. No utility can automatically convert Batch Pilot panels or DotEdit panels to Datacap Desktop panels. You must manually create custom panels by using the Datacap Developer Kit (DDK) for the target product version. For more information, see Customized panel conversion to Datacap Desktop.
- Troubleshooting
-
- Issue: When you convert an older framework custom panel to Datacap Desktop, you receive a "file not found exception. For example, in Creating the Datacap Desktop in Microsoft Visual Studio, step 4 ("In the Layout XML field, click Browse and select the XML file that you generated"), you receive the "file not found" exception.
- Solution: Complete the following steps:
- In Visual Studio, open the DCDesktopPanels solution that contains the DotEditPanels project.
- Set the path to your project by editing the file dotMaster.cs and locate the following line in the file:
string sProjectRoot = "";
- Update the empty string with the full path to the directory that contains your project and save the file.
The solution and details for creating Datacap Desktop customized screen panels is in the PDF format Desktop Custom Panels guide in the DDK package.
- For DDKs for V9.1.5 interim fix 4 and earlier versions, go to IBM Datacap Desktop custom panels.
- For DDKs for V9.1.5 interim fix 5 and later versions, go to ibm-ecm/datacap-developer-kit.
- DDKs contain detailed documentation.
Plan and test
Procedure
Troubleshooting upgrades
The following issues can occur during an upgrade. Possible solutions are provided.
- Error: "Could not locate RRX code Barcode_x" when you run Batch Profiler. Noted when migrating from V9.1.3 to V9.1.4.
-
- Solution:
- Copy PageID.rrx from the target version of the APT application to the Migrated copy of APT applications that are connected to Oracle/SQL/DB2® databases in the rules folder.
- Error when you run a batch: Action execution failed; Type mismatch.
-
- Example:
-
- Error message:
- Microsoft VBScript runtime error - Type mismatch.
- Cause
- Rules are modified in Validations.dll. At the time that the function was created, an action of the same name AllowOnlyChars existed in invoice.rrx & validations.rrx.
- Solution:
- Create a private function called Characterizations. Modify Invoice and Validations actions to call the private function.
- Error: Unable to connect to admin database or engine database.
-
- Explanation:
- You attempt to log in by using Taskmaster Web or another Datacap client. You get an error message that you are unable to connect to the admin database or the engine database.
- Solution:
- See technote Unable to connect to admin database with IBM Datacap Taskmaster Capture.
- Error: Any of the following actions libraries access errors, typically when you update from V8.x:
- Could not load file or assembly
- Action parameters don't match RRX specification.
- Error retrieving RRX library description: "Couldn't access action library".
- Possible solutions:
- Rebuild and reinstall customized .NET actions.
- When you migrate from an earlier version of Taskmaster, any application-specific RRX files must be modified to remove the ".rrx" extension from included library references. Edit the custom or application-specific RRX file and modify XML <i> tags as needed. See technote Couldn't locate RRX code with IBM Datacap Taskmaster Capture..
- Verify the path to the global rulesets and actions location (and other possible solutions). See technote Couldn't access action library error in Datacap Studio in IBM Datacap Taskmaster Capture.
- Register .NET action components properly. See technote Custom Taskmaster .NET action reports couldn't load needed object error in IBM Datacap Taskmaster Capture
- In Datacap Studio, the workflow in the Test tab is blank
-
- Solution:
-
Use DBCopy to copy all data from Microsoft Access database to a new database.
- In Application Manager all fields are unavailable. Encountered when you migrate from V8.x.
-
- Possible solutions:
-
- Copy the C:\datacap\tmclient\tabs.XML file from an error-free system with an identical installation to the same location on the problem system. See technote Application Manager greyed out in IBM Datacap Taskmaster Capture.
- See technote Taskmaster Application Manager fields are disabled using IBM Datacap Taskmaster Capture
- See technote Settings are disabled with Taskmaster Application Manager in IBM Datacap
- Batches hang or stop before completion due to an out-of-memory condition.
-
- Solution:
- Replace Datacap 32-bit actions with Datacap 64-bit actions. 64-bit actions are available in Datacap V9.1.6 and later versions.
- Warning 1946.Property ‘{9F4C2855-9F79-4B39-A8D0-E1D42DE1D5F3}, 12' for shortcut 'Datacap Accounts Payable Demo Vendor Tool.lnk' could not be set.
-
- Cause:
- The warning can occur if you did not add the APT application in the Custom Setup menu of the Datacap installer. A similar message can occur if you did not add the Medical Claims application during installation. Noted during upgrade from V8.x.
- Solution:
- Install again and include the APT application.
Was this topic helpful?
Document Information
Modified date:
08 September 2020
UID
ibm16218954