IBM Support

Upgraded Control Center to 6.1.2.0 from 6.1.1.0 and now can not access the Web Console or Launch Page.

Troubleshooting


Problem

Upgraded Control Center to 6.1.2.0 from 6.1.1.0 and now can not access the Web Console or Launch Page.
After completing the upgrade and running configCC and starting the application, we're unable to access the url: ICC-hostname:58082

Symptom

ICC Engine log shows  [WebAppServerStarter] INFO  WLPStarter - CRUL040E Return value: 22. User Operation: CMD  Rule: WLPStarter
WebSphere message.log has nothing after CWWKE0001I: The server defaultServer has been launched.
FFDC log being created
Exception = java.lang.VerifyError Source = com.ibm.ws.kernel.launch.internal.LauncherDelegateImpl probeid = 105 Stack Dump = java.lang.VerifyError: JVMVRFY041 invokespecial of wrong initializer; class=com/ibm/ws/kernel/launch/internal/ServerCommandListener, method=init(ILjava/io/File;)V, pc=628

Cause

A defect in the third party Wily application customer had added to WebSphere in an earlier release.

Please note that the below link is not an IBM link, it is from CA support.

https://comm.support.ca.com/kb/java-lang-verifyerror-jvmvrfy041/kb000124396

Diagnosing The Problem

Look at the ICC Engine log and WebSphere logs

Resolving The Problem

alter the jvm.options file back to the default at <ICC install>/web/wlp/usr/servers/defaultServer

Related Information

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Component":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"6.1.2.0","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

ibm10884406