Question & Answer
Question
How do I successfully upgrade a Tivoli Storage Manager Version 6 server?
Cause
The Tivoli Storage Manager V6 server delivered many significant changes to the architecture of the product. The most notable change is the replacement of the proprietary embedded database by the IBM DB2 database. Because of the complexity of the DB2 product, there is an installation wizard that simplifies the installation of the components required to install and run a V6 server. The installation wizard is complex and might require some guidance.
Answer
The following sections provide information to help ensure a successful Tivoli Storage Manager V6 upgrade.
Pre-installation steps
Important guidelines
Deployment Engine issues
Pre-upgrade issues
Problems running the db2ckupgrade script
Component fails to install
Server fails to start after successful component upgrade
Problems after successfully starting an upgraded server
Problem Determination Guide
Pre-installation steps
To prepare for the server upgrade, review the following information:
- In the installation guide, read about upgrading the server.
V6.3:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r3/index.jsp?topic=/com.ibm.itsm.srv.install.doc/t_srv_upgrade.html
V6.2:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r2/index.jsp?topic=/com.ibm.itsm.srv.install.doc/t_srv_upgrade.html
- For any special instructions or specific information for your operating system, review the release notes and readme files.
V6.3:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r3/index.jsp?topic=/com.ibm.itsm.relnotes.doc/relnote_server630.html
V6.2:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r2/topic/com.ibm.itsm.relnotes.doc/r_relnotes_srv.html
- Review the system requirements for the new server.
V6.3:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r3/index.jsp?topic=/com.ibm.itsm.srv.install.doc/t_srv_inst_overvu.html
V6.2:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r2/topic/com.ibm.itsm.srv.install.doc/t_srv_inst_overvu.html
- If you are upgrading to a V6 server for the first time, read about server deployment: http://www.ibm.com/support/docview.wss?uid=swg21421060
Prepare your system environment for the upgrade. Detailed preparation steps are described in the technical documentation. The following list includes key tasks:
- To administer your Tivoli Storage Manager V6 servers, install a Tivoli Storage Manager V6 Administration Center:
ftp://ftp.software.ibm.com/storage/tivoli-storage-management/maintenance/admincenter/
- Back up your current server database and configuration files.
- For each existing server instance, gather information about the corresponding DB2 instance. Collect the default database path, database name, database alias, database path, and any DB2 variables configured for the instance.
Tip: If you are upgrading to Tivoli Storage Manager V6.2.2 on AIX, Linux, HP-UX, or Solaris, verify that the db2level command works (/opt/tivoli/tsm/db2/bin/db2level). If it returns an error, there might be an issue with upgrading DB2 and you should not install Tivoli Storage Manager V6.2.2. Instead, directly install Tivoli Storage Manager V6.2.2.1, the version in which this issue was resolved. If you already installed Tivoli Storage Manager V6.2.2 and are experiencing issues with starting your server, you might need to manually upgrade the server instances. See the following topic:
http://www.ibm.com/support/docview.wss?uid=swg27018195
Back to top
Important guidelines
Attention: Do not alter the DB2 software that is installed with Tivoli Storage Manager installation packages and fix packs. Do not install or upgrade to a different version, release, or fix pack of DB2 software because doing so can damage the database.
Before starting the upgrade, consider the following additional guidelines:
- The Tivoli Storage Manager V6 installer is capable of upgrading your server without first having to uninstall the product. It handles both new installations and upgrades. Do not uninstall Tivoli Storage Manager products unless you are planning to completely remove Tivoli Storage Manager from your system.
- Never remove the Deployment Engine from your system because this can cause problems when installing DB2. The DB2 installation is registered in the Deployment Engine. Therefore, the installer is dependent on a valid Deployment Engine to determine whether it should install or upgrade DB2. The installer also depends on the Deployment Engine to determine if the DB2 configuration must be run after the upgrade.
- After completing the upgrade, back up the Deployment Engine again.
If issues are detected, review the information in the following sections. The links contain information about known issues with upgrading a Tivoli Storage Manager server. Most of these issues either have a workaround or describe where the problem has been fixed. Not everyone will see these errors, but given the time-sensitive nature of upgrade, it is recommended that you review the items. That way, if you encounter issues, you will be aware of the solution.
Back to top
Deployment Engine issues
Deployment Engine failed to initialize because lock files exist
Deployment Engine failed to initialize due to invalid host name
Installation ends without installing components after Deployment Engine initialization
Back to top
Pre-upgrade issues
The installer prompts for old instance credentials during upgrade
Back to top
Problems running the db2ckupgrade script
Permission errors with db2ckupgrade executable
Incorrect DB2 authentication
Back to top
Component fails to install
If the server or storage agent upgrade fails, try installing the native package directly. To find the native packages for the server, go to the following directory in your installation media:
<installation media>/COI/PackageSteps/TSM_Server/FILES/TIV-TSMSRV-<platform>
If the DB2 upgrade fails, check the following directories for any logs containing the errors. In particular, look for a db2setup.log or installFixpack.log file:
- UNIX and Linux:
/opt/tivoli/tsm/_uninst/plan/tmp/
/opt/tivoli/tsm/_uninst/plan/logs/
/var/tivoli/tsm/
- Windows:
C:\Program Files\Tivoli\TSM\_uninst\plan\tmp\
C:\Program Files\Tivoli\TSM\_uninst\plan\logs\
C:\Program Files Tivoli\TSM\
Ensure that DB2 is registered in the Deployment Engine and is at the correct level.
- UNIX and Linux:
/usr/ibm/common/acsi/bin/de_lsrootiu.sh
/opt/tivoli/tsm/db2/install/db2ls
- Windows:
C:\Program Files\IBM\Common\acsi\bin\de_lsrootiu.cmd
C:\Program Files\Tivoli\TSM\db2\bin\db2level.exe
If the client API installation fails, check for any existing versions of the Client API and try to remove them. Then, reinstall the Tivoli Storage Manager server to install the Client API. See APAR IC72401. You can also try to install the native packages.
DB2 fails to upgrade on Windows when no instances have been created
Server fails to start after successful component upgrade
- Manually upgrading server instances from Tivoli Storage Manager Version 6.1 to Version 6.2
- Server fails to start on Windows
- Server fails to upgrade multiple instances on Windows
- Some tables may not be renamed correctly during an upgrade to V6.2 (fixed in 615 and 622)
- DB2 incorrectly reports "local database directory" to be "%s" (fixed in 614 and 621)
Back to top
Problems after successfully starting an upgraded server
- Database backup fails with sqlcode -2133 and sqlerrmc 106
- Known issues with SELECT statements
- Tivoli Storage Manager backup-archive client has disappeared
Back to top
Problem Determination Guide
For additional information, see the Problem Determination Guide.
V6.3:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r3/index.jsp?topic=/com.ibm.itsm.tshoot.doc/b_problem_deter_guide.pdf
V6.2:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r2/topic/com.ibm.itsm.tshoot.doc/b_problem_deter_guide.pdf
Back to top
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21455299