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updateJDK.cmd command is leading error The system cannot find the path specified

Troubleshooting


Problem

Attempts to run updateJDK.cmd command leads to the error The system cannot find the path specified in IBM Sterling Order Management

Symptom

To simulate, Go to <Sterling Install Dir>\bin and run the command updateJDK.cmd:
> updateJDK.cmd/updateJDK.sh REPLACE IBM\WebSphere\AppServer\java_1.7.1_64.

The error: "The system cannot find the path specified" appears.

Cause

The updateJDK does not work in 9.3 version.

Diagnosing The Problem

The upgrade of Sterling JDK is being performed from 1.6 to 1.7.

Resolving The Problem

The command updateJDK should not be used in Sterling OMS version 9.3. Though it is available under bin folder but it is not meant to be used in 9.3 version. It works fine in Sterling OMS 9.4 FP7 onwards only.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22013267