IBM Support

Uninstalling Rational Rhapsody leads to error "“Error opening installation log file..."

Troubleshooting


Problem

Attempts to uninstall IBM Rational Rhapsody results in error "“Error opening installation log file. Verify that the specified location exists and is writable.”

Symptom

You receive the following error message

image


Cause

This can occur if Windows Installer Logging is enabled, but the Windows Installer engine cannot properly write the uninstallation log file. This condition can occur if the Windows Installer's application heap becomes freed and thus loses the information on where to store the log file. When this occurs, Windows Installer attempts to write to the location 'C:\Windows\System32' and addresses it as a file. Proper behavior would be to write to the following location and file name: 'C:\Users\<username>\AppData\Local\Temp\MSIxxxxxx.log'.

Microsoft has confirmed this to be a problem in Windows 7 Operating System

Environment

Windows 7

Resolving The Problem

In order to resolve the problem you may stop and restart the Explorer.exe process using Task Manager.

More information on the same can be found at Microsoft KB

Related Information

[{"Product":{"code":"SSB2MU","label":"IBM Engineering Systems Design Rhapsody"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.0;8.0.2;8.0.1;8.0.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Product Synonym

Rational Rhapsody

Document Information

Modified date:
27 May 2022

UID

swg21644103