IBM Support

"Undefined" error when attempting to add a parameter via bi/utils/ConfigSetter.html

Troubleshooting


Problem

When attempting to add a parameter via the ConfigSetter.html tool, a Dialog Box containing an error message appears.
The error is:   Undefined

 

Symptom

Cannot add parameter via ConfigSetter.html

Happens in all Browsers

Dialog box contains "undefined".

Cause

This is caused by not being authenticated to the Cognos Analytics Software prior to attempting to add the Parameter.

Environment

All Platforms.

Resolving The Problem

Open a new Tab in the Browser.   
Authenticate to Cognos Analytics using the same host/port that you will use for the ConfigSetter.html

For example:

If you ultimately are going to be using http://machine.domain.com:9300/bi/utils/ConfigSetter.html

Then you should authenticate in a tab against http://machine.domain.com:9300/bi.

Afterwards, open a new tab and run configsetter in that.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"Administration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
12 September 2018

UID

ibm10731369