Troubleshooting
Problem
Unable to start IBM Planning Analytics Spreadsheet Services and IBM Cognos TM1 service in parallel on the same host server.
Symptom
- IBM Cognos TM1 service and IBM Planning Analytics Spreadsheet service fail to run in parallel while configured on the same host server.
- IBM Planning Analytics Spreadsheet service runs without any issues when IBM Cognos TM1 service is in stopped state and vice-versa.
Cause
The issue experienced is likely due to a port conflict. Please ensure that each application is configured to use unique ports.
Resolving The Problem
- IBM Planning Analytics Spreadsheet services uses port 9510 by default hence ensure that IBM Cognos TM1 service is configured to run using different port number.
- The port number for IBM Cognos TM1 service can be changed using IBM Cognos Configuration.
- The jvm.options for IBM Cognos TM1 service (tm1_64\wlp\usr\servers\tm1\) and IBM Planning Analytics Spreadsheet services (tm1web\wlp\usr\servers\tm1web\) may contain additional port assignments, for example: -Dcom.sun.management.jmxremote.port=7999
- Any port assignments must use ports that are not used by any other application
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzJJAA0","label":"Installation and Configuration->TM1 Web"}],"ARM Case Number":"TS004001346","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
10 August 2020
UID
ibm16257757