Troubleshooting
Problem
Command line "./cogconfig.sh -s" did not work although we could start Cognos Service from IBM Cognos Configuration.
In addition, we are able to stop it through - ./cogconfig.sh -stop
In addition, we are able to stop it through - ./cogconfig.sh -stop
Symptom
Cause
"cogstartup.lock" file was created under <Cognos install directory>/configuration folder.
Diagnosing The Problem
The following error message was output to "cogconfig_response.csv."
ERROR, "[main]", "The configuration data is locked by another instance of IBM Cognos Configuration."
ERROR, "[main]", "The configuration data is locked by another instance of IBM Cognos Configuration."
Resolving The Problem
Deleting "cogstartup.lock" file from configuration folder resolved this issue. Make sure there is no Cognos Configuration process has been executed.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"TS006376642","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions"}]
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Document Information
Modified date:
10 August 2021
UID
ibm16480247