IBM Support

Unable to see shipment information in IBM Call Center For Commerce for imported shipments

Troubleshooting


Problem

Attempts to import sales order does not show up the purchase order shipment information in IBM Call Center for Commerce UI.

Symptom

When a sales order along with its corresponding purchase order and purchase order shipment, is imported in Sterling Order Management System using importOrder and importShipment APIs, the Purchase Order’s shipment information is not available when accessed through IBM Call Center For Commerce UI.

Steps to Replicate:

  1. Create a drop ship order. Create chained order. Take chained PO to shipped status.


  2. Access the SO in Web call Center. Click on Where is my Shipment related task.
    As a result, the shipment information is displayed on the UI


  3. Now import a sales order and associated purchase order using the importOrder API calls. Below xmls are for reference -
    --Sales Order Import input
    <Order DocumentType="0001" EnterpriseCode="DEFAULT"   NewRecord="Y" OrderDate="2016-07-21" OrderNo="SO1001" OrderHeaderKey="SOHK1" >
       <OrderLines>
           <OrderLine DeliveryMethod="SHP" OrderedQty="1" PipelineKey="SO_PIPELINE_KEY" PrimeLineNo="1" ShippedQuantity="1" SubLineNo="1" OrderLineKey="SOLK1">
               <Item ItemDesc="ITEM" ItemID="ITEM" ProductClass="" UnitOfMeasure="EACH"/>
               <PersonInfoShipTo Country="US" />
               <OrderStatuses>
                   <OrderStatus Status="3700" StatusQty="1">
                       <Schedule ShipNode="NODE1"/>
                   </OrderStatus>
               </OrderStatuses>
           </OrderLine>
       </OrderLines>
       <PersonInfoBillTo Country="US" />
    </Order>


    Purchase Order import input

    <Order ChainType="DROP_SHIP" DocumentType="0005" EnterpriseCode="DEFAULT" OrderDate="2016-07-21" OrderNo="PO1001" OrderHeaderKey="POHK1">
       <PersonInfoBillTo Country="US" />
       <OrderLines>
           <OrderLine OrderedQty="1" PipelineKey="PO_PIPELINE_KEY" PrimeLineNo="1" ShipNode="NODE1" OrderLineKey="POLK1">
               <PersonInfoShipTo Country="US" />
               <Item ItemDesc="ITEM" ItemID="ITEM " ProductClass="" UnitOfMeasure="EACH"/>
               <DerivedFrom DocumentType="0001" EnterpriseCode="DEFAULT" OrderNo="SO1001" OrderLineKey="SOLK1" PrimeLineNo="1" SubLineNo="1"/>
               <OrderStatuses>
                   <OrderStatus Status="3700" StatusQty="1">
                       <Schedule ShipNode="NODE1"/>
                   </OrderStatus>
               </OrderStatuses>
           </OrderLine>
       </OrderLines>
    </Order>


  4. Call importShipment API to import the corresponding shipment. Below is the input xml for reference –
    <Shipment ActualShipmentDate="" DocumentType="0005" EnterpriseCode="DEFAULT" OrderAvailableOnSystem="Y" OrderNo="PO1001" PipelineKey="PO_PIPELINE_KEY" SellerOrganizationCode="ORG1" ShipNode="NODE1" ShipmentNo="POS1001" Status="1400" TrackingNo="T101" >
      <ToAddress Country="US" />
       <FromAddress Country="US" />
       <ShipmentLines>
           <ShipmentLine DocumentType="0005" EnterpriseCode="DEFAULT" ItemID="ITEM" OrderNo="PO1001" OrderLineKey="POLK1" PrimeLineNo="1" ProductClass="" Quantity="1" ShipmentLineNo="1" SubLineNo="1" UnitOfMeasure="EACH" >
           </ShipmentLine>
       </ShipmentLines>
       <Containers>
           <Container ContainerNo="C-101" TrackingNo="T101">
               <ContainerDetails>
                   <ContainerDetail Quantity="1">
                       <ShipmentLine DocumentType="0005" EnterpriseCode="DEFAULT" ItemID="ITEM" OrderNo="PO1001" OrderLineKey="POLK1" PrimeLineNo="1" ProductClass="" Quantity="1" ShipmentLineNo="1" SubLineNo="1" UnitOfMeasure="EACH">
                   </ShipmentLine>                
                 </ContainerDetail>
               </ContainerDetails>
           </Container>
       </Containers>
    </Shipment>


  5. Access the imported sales order in web call center. Navigate to Where is my Shipment link.

    As a result, Shipment information not available message is displayed on the UI

Cause

ChainedFrom element is not supported by importOrder API

Diagnosing The Problem

Orders need to be imported from third party system to Sterling OMS

Resolving The Problem

As an alternate solution, you need to pass
<OrderLine ChainedFromOrderHeaderKey=""  ChainedFromOrderLineKey="">
within Purchase Order giving the details of Sales Order.

At the same time, the Sales Order should have the following details corresponding to the purchase order.
<OrderStatus ChainedToOrderLineKey="" ChainedToOrderHeaderKey="" >

Please see the complete input xmls for reference:

SO importOrder input

<Order DocumentType="0001" EnterpriseCode="DEFAULT"   NewRecord="Y" OrderDate="2016-07-21" OrderNo="SO1001" OrderHeaderKey="SOHK1" >
    <OrderLines>
        <OrderLine DeliveryMethod="SHP" OrderedQty="1" PipelineKey="SO_PIPELINE_KEY" PrimeLineNo="1" ShippedQuantity="1" SubLineNo="1" OrderLineKey="SOLK1">
            <Item ItemDesc="ITEM" ItemID="ITEM" ProductClass="" UnitOfMeasure="EACH"/>
            <PersonInfoShipTo Country="US" />
            <OrderStatuses>
                <OrderStatus Status="3700" StatusQty="1" ChainedToOrderLineKey="POLK1" ChainedToOrderHeaderKey="POHK1" >
                    <Schedule ShipNode="NODE1"/>
                </OrderStatus>
            </OrderStatuses>
        </OrderLine>
    </OrderLines>
    <PersonInfoBillTo Country="US" />
</Order>


PO importOrder input

<Order ChainType="DROP_SHIP" DocumentType="0005" EnterpriseCode="DEFAULT" OrderDate="2016-07-21" OrderNo="PO1001" OrderHeaderKey="POHK1">
    <PersonInfoBillTo Country="US" />
    <OrderLines>
        <OrderLine OrderedQty="1" PipelineKey="PO_PIPELINE_KEY" PrimeLineNo="1" ShipNode="NODE1" OrderLineKey="POLK1" ChainedFromOrderHeaderKey="SOHK1" ChainedFromOrderLineKey="SOLK1">
            <PersonInfoShipTo Country="US" />
            <Item ItemDesc="ITEM" ItemID="ITEM " ProductClass="" UnitOfMeasure="EACH"/>
            <DerivedFrom DocumentType="0001" EnterpriseCode="DEFAULT" OrderNo="SO1001" OrderLineKey="SOLK1" PrimeLineNo="1" SubLineNo="1"/>
            <OrderStatuses>
                <OrderStatus Status="3700" StatusQty="1">
                    <Schedule ShipNode="NODE1"/>
                </OrderStatus>
            </OrderStatuses>
        </OrderLine>
    </OrderLines>
</Order>

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Sterling Call Center","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.4;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21987627