IBM Support

Unable to record keystrokes when connected to IBM\Rational XDE Tester with VPN software

Troubleshooting


Problem

When users connect to a computer with IBM Rational XDE Tester® from a remote location via pcAnywhere®, Remote Admin, VCN or some other type of VPN software, XDE Tester may fail to record keyboard input.

Cause

XDE Tester is not configured to record remotely generated keystrokes.

Resolving The Problem

Using XDE Tester via VPN software is not supported.

Nevertheless, using XDE Tester in this fashion may work. In particular, users can try to capture remotely generated keystrokes by editing the registry of the computer on which XDE Tester is located:

  1. Close XDE Tester
  2. Select Start > Run, type regedit and click OK
  3. Back-up the registry before modifying it
    1. Select Registry > Export
    2. In the dialog box, specify a file name and location, select 'All' for Export Range and click Save.
  4. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Rational Software\Rational Test\8 so that the 8 folder is highlighted
  5. Select Edit > New > String Value and name it 'Rational FT Record Injected Keys' (the name should not include the quotation marks)
  6. Set the new key's value to 1 and close the registry

This new registry key may interfere with keystroke recording for keystrokes entered with an Input Method Editor (IME).




[{"Product":{"code":"SSSHZT","label":"Rational XDE Tester"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.00;2003.06.01;2003.06.12;2003.06.13;2003.06.10","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
16 June 2018

UID

swg21168040