IBM Support

Unable to read region names from the IBM Rational ClearCase registry; validation of region names will be disabled.

Troubleshooting


Problem

This technote explains how to resolve an error, Unable to read region names from the ClearCase registry; validation of region names will be disabled, that can occur when opening the IBM Rational ClearCase control panel.

Symptom

You may see the following warning when opening the ClearCase control panel from the GUI or command line :



Unable to read region names from the ClearCase registry; validation of

region names will be disabled.

Cause


This error occurs any time the ClearCase control panel can not get a region list from the ClearCase registry server.

Possible causes include the following:

  • The albd server process on the registry server has failed to start or has unexpectedly shut down
  • A local firewall on the client host is not allowing TCP and or UDP connections to port 371 on the registry server
  • Network communications to ClearCase registry server are blocked by intervening firewalls

Resolving The Problem

Since this issue is normally a communication issue, the easiest approach is to check the other end of the link (the albd server process on the registry server) to verify that it is running.

If the registry server is running on a Microsoft Windows host:

Verify that the albd_server.exe process is running in the Windows task manager and that the ClearCase control panel works correctly on the registry server.

Task Manager:




ClearCase control panel:



If the registry server is running on a Unix host:

Verify that the albd server process is running by opening a remote shell (telnet, ssh, etc.) to that server and running "ps -ef | grep albd".

Observe the output similar to the following:

bash-2.05$ ps -ef | grep albd
    root   427     1   0 12:15:22 ?           0:00 /opt/rational/clearcase/etc/albd_server
  user1 1723  1720   0 12:04:51 pts/2       0:00 grep albd

Then, while still on the server, run "cleartool lsregion" and verify that you get at least one line of output.

For example:
bash-2.05$ cleartool lsregion
Unix
Windows
region2


Troubleshoot the connections:

If the albd server is running on the registry server, and responds correctly from there, the next step is to troubleshoot the connections.

Some important questions:

  • Can other clients reach the albd on the registry server?
  • If so, where are these clients in relation to the non-functional ones? (Physically and on the network -- different buildings or floors or VLANs or subnets?)
  • Does the cleartool lsregion command work on the impacted client(s)? If the issue is a client-side firewall issue, it is possible that some commands will work while other commands or GUIs will fail.

If the albd server is not running, then the best option is to check the system logs (on Unix, see /var/adm/rational/clearcase/albd_log, on Windows, open the event view and look in the "application" log) to see if the albd reported any errors before shutting down. Attempt restarting the albd service using the appropriate operating system commands.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"GUI: Control Panel","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.1;7.1;7.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21441083