Troubleshooting
Problem
createOrder API fails when order is being created by IBM Call Center (RCP COM) with invalid currencies
Symptom
Creating an order through COM throws the error :
Caused by: <?xml version="1.0" encoding="UTF-8"?>
<Errors>
<Error ErrorCode="YFS10325" ErrorDescription="YFS: Invalid currency" ErrorRelatedMoreInfo="">
<Attribute Name="ErrorCode" Value="YFS10325"/>
<Attribute Name="ErrorDescription" Value="YFS: Invalid currency"/>
<Attribute Name="CURRENCY" Value="Locale Currencies"/>
<Stack>com.yantra.yfc.util.YFCException
at com.yantra.util.YFCCurrencyUtils.validateCurrency(YFCCurrencyUtils.java:542)
at com.yantra.omp.business.order.manage.YFSOrderValidator.fillCurrency(YFSOrderValidator.java:255)
at com.yantra.omp.business.order.manage.YFSOrderValidationIterator.doOrderHeaderActions(YFSOrderValidationIterator.java:198)
at com.yantra.omp.business.order.manage.YFSOrderIterator.iteratorOrderHeader(YFSOrderIterator.java:60)
at com.yantra.omp.business.order.manage.YFSOrderValidationIterator.startValidation(YFSOrderValidationIterator.java:156)
at com.yantra.omp.business.order.manage.YFSManageOrder.handleChanges(YFSManageOrder.java:1734)
at com.yantra.omp.business.order.manage.YFSManageOrder.internal_processManageOrder(YFSManageOrder.java:1048)
at com.yantra.omp.business.order.manage.YFSManageOrder.processManageOrder(YFSManageOrder.java:986)
at com.yantra.omp.business.order.manage.YFSManageOrder.manageOrder(YFSManageOrder.java:656)
at com.yantra.omp.business.order.manage.YFSManageOrder.createOrder(YFSManageOrder.java:386)
at com.yantra.omp.business.document.YFSDocumentManagerImpl.create(YFSDocumentManagerImpl.java:78)
at com.yantra.omp.api.YFSApiImpl.createOrder(YFSApiImpl.java:658)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:95)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:56)
at java.lang.reflect.Method.invoke(Method.java:620)
Cause
This was due to locale not present present in com.ini
Environment
COM 9.3
Resolving The Problem
This issue is not an often occurrence.
Add en_US to com.ini.sample.
com.ini.sample is located on the server (rcpdrop directory : where com.zip will be built and used on the client systems.)com.ini.sample is renamed to com.ini on the client systems when the files are extracted
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg22010626