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Unable to connect to the engine

Troubleshooting


Problem

The engine is taking an excessive amount of time to start.

Symptom

The Sterling Control Center engine is taking an excessive amount of time to start. After the Control Center Web HTTP /HTTPS port (port 58082 by default) has started the user can get the Java Launch page to display but when the log in screen appears and they try to log in they get the error:
Unable to connect to Engine.
- Verify that the Host Name and Port Number are correct.
- If the Host Name and Port Number are correct, then the engine may not be running.

Cause

The error is caused because the engine has not yet completed startup.

Diagnosing The Problem

The Engine Startup log ends with:
INFO EngineStartup - Starting ...StatisticsService

It shows that StatisticsService is starting but is not yet started.

The Engine log shows:
INFO SCCEngine - Statistics Service starting recovery of unprocessed events...
INFO SCCEngine - Recovering data for "server-name"
INFO SCCNotificationJdbcDAO - SCNotificationJdbcDAO.getStats() initiating query: SELECT * FROM ( SELECT XML_STRING,USER_DATA_1,USER_DATA_2,USER_DATA_3,USER_DATA_4,SERVER_DATA_1,SERVER_DATA_2,SERVER_DATA_3,SERVER_DATA_4,SERVER_DATA_5,SERVER_DATA_6,SERVER_DATA_7,SERVER_DATA_8,SERVER_DATA_9,SERVER_DATA_10,ACTION_ID,ACTIONS_COMPLETED,ALERT,ALERT_DELETED,DATE_TIME,DEST_FILE,EMAIL_FLAG,EVENT_ID,EVENT_TYPE,FILE_SIZE,FROM_NODE,MSG_ID,NODE_ID,NODE_NAME,NODE_TYPE,ORIG_NODE,PERCENT_COMPLETE,PROC_ID,PROC_NAME,REMOTE_NODE,RET_CODE,RULE_ID,RULE_INSTANCE_ID,SEQ_NUM,SHORT_MSG,SLC_FLAG,SLC_ID,SLC_INSTANCE_ID,SLC_SOURCE_1,SLC_SOURCE_2,SLC_SRC_EVENT_ID,SOURCE_FILE,STEP_NAME,SUBMITTER,TRAP_FLAG,XFER,XFER_DIRECTION,USER_OP_FLAG FROM EVENTS WHERE XFER = 'Y' AND NODE_ID = 'CD-NODE' AND ((DATE_TIME='1970/01/01 00:00:00.000' AND SEQ_NUM>0) OR (DATE_TIME>'1970/01/01 00:00:00.000')) ORDER BY DATE_TIME ASC, SEQ_NUM ASC ) WHERE ROWNUM < 10001
INFO SCCNotificationJdbcDAO - SCCNotificationJdbcDAO.getStats() query complete

These lines are generated for each managed node. If the engine cannot retrieve the required data then the query is retried numerous times.

Resolving The Problem

To resolve the problem consider disabling the recovery feature. This can be done by editing the StatisticsService.xml file in the ...\ControlCenter5.4.2\conf\services\system directory.
Find the line:
<doRecovery>true</doRecovery>
change true to false, save the file then stop and start Sterling Control Center.

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.4.2.1;5.4.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg21697030