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Unable to Change password in MAS for a userid. Error: "Operation failed. AIUCO1003E: You are not authorized to perform the requested action"

Troubleshooting


Problem

Users are unable to change the password by using the option - "Change password".
Steps to reproduce:
1) Go to Users Administration in MAS UI:
     (i) Add User with below details
     Display Name: John Conn
     Username: John.Conn
             NOTE: Camel cases are required to reproduce this issue, hence J, and C are in capital letter here
     Primary email: john.conn@localhost.com
     Password: maxadminmaxadmin
    (ii) Create user
2) Logout from MAS admin user and login with John.Conn userid.
    (i) Go to Profile > Manage Profile
        Click Change Password
        Current Password: maxadminmaxadmin
        New/Confirm Password: maxadminmaxadmin1
        Click Save
RESULT: You get the error- "Operation failed. AIUCO1003E: You are not authorized to perform the requested action".

EXPECTED RESULT: User should be allowed to change the password.

Cause

User ID is created in caps. Example in this case, the userid is "John.Conn".

Environment

Maximo Application Suite 8.6

Resolving The Problem

This issue is already resolved in the MAS version: 8.7.
And in MAS version: 8.6, the issue occurs only for the user IDs having camel case letters, for example the userid - John.Conn. If, the userids are created with small case, for example john.conn1 - the issue with Change Password will not be seen.
As a work around for these versions - MAS 8.6, below are the suggested steps:
    1) Try creating userid's with small case letters.
    2) If for any reason, the userid is to be created with upper case as shown above, the workaround is to use the Replace/Forgotten password functionality to change the password.

Document Location

Worldwide

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Document Information

Modified date:
10 March 2022

UID

ibm16561613