Troubleshooting
Problem
User launches Architect. User double-clicks on a TM1 cube (TM1 server). User types in their username/password. An error appears.
Symptom
The exact error will depend on the environment. Below are some examples:
TM1 Architect with older version of Cognos BI:
TM1 Login
IBM Cognos Software
Unable to authenticate. The provided credentials are restricted from accessing IBM Cognos. Please contact your administrator.
TM1 Architect with modern version of Cognos Analytics:
Cause
The username does not belong to any Cognos BI security role/group (inside the 'Cognos' security namespace).
Diagnosing The Problem
Launch the Cognos Connection website, and logon as that same 'bad' user. An error similar to the following will appear:
IBM Cognos Analytics
Unable to authenticate. The provided credentials are restricted from accessing IBM Cognos. Please contact your administrator.
IBM Cognos Analytics
Unable to authenticate. The provided credentials are restricted from accessing IBM Cognos. Please contact your administrator.
Resolving The Problem
Make sure that the Cognos BI user (used to logon to the TM1 server/cube) is a member of at least one role (inside Cognos BI's Cognos Connection website).
[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Architect","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
25 October 2019
UID
swg22015593