IBM Support

** Troubleshooting** "HRESULT: 0x8002000B (DISP_E_BADINDEX)" when using Excel-based functions (such as opening data entry form)

Question & Answer


Question

User clicks 'Company - Data Entry - Reported Values'. User chooses parameters and clicks 'Open'. An error appears: Standard Error: Source: Microsoft.Office.Interop.Excel Description: Invalid index. (Exception from HRESULT: 0x8002000B (DISP_E_BADINDEX).....

Cause

There are several possible causes for this error:

Scenario #1 (most likely) - Defect (reference APAR PI49912) in early versions of Controller 10.2.1 (10.2.5110.95 and earlier).

  • This is triggered when the client device has an incompatible Excel add-in(s) installed (alongside the Cognos Controller Excel add-in).

Scenario #2 - Microsoft Excel (on the client device) has not been activated.

Answer

Scenario #1
Upgrade to Controller 10.2.1 Fix Pack 2 (10.2.5120.72) or later.

  • See separate IBM Technote #1963875.

Scenario #2
Activate the license of Microsoft Excel (on the client device).
  • See separate IBM Technote #1967095 for full details.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21965510