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** Troubleshooting ** 'File access is denied ... dbf' error when running a consolidation

Troubleshooting


Problem

User runs a consolidation. Afterwards, user opens the batch queue. The job finished with error.

If the user double-clicks on the entry, then (inside the details) there is a message 'File access is denied'.

Symptom

The error will vary, but it will contain text similar to:

File access is denied c:\...\<username?\batch_id_0000008177\fd1t8b8f.dbf.

Example #1:

Number:    5
Source:    System.Web.Services
Description:    System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Exception: File access is denied c:\...\<username?\batch_id_0000008177\fd1t8b8f.dbf. (Error occured within method=RunConsol in the module with progid=FrMiscBT.ConsBusinessT)
   at Microsoft.VisualBasic.ErrObject.Raise(Int32 Number, Object Source, Object Description, Object HelpFile, Object HelpContext)
   at ControllerServerCommon.RaiseErrSrv.RaiseError(String sUser, Int32 lErrNo, String sErrSource, String sErrDesc, String sErrHelpFile, Int32 lErrHelpContext)
   at FrBatchBT.clsBatchT.Batch(String sGuid, String sUser, Int16 iProcessId, String sJobName, String sParams, Int32 lRegDate, Int32 lRegTime, Int32 lSchedDate, Int32 lSchedTime, Int16 iScheduleType, String sUdl, Int32 lDependentBy, String sTimeChain, Boolean bBatchMode)
   at Cognos.Controller.Proxy.CCRWS.clsBatchT_Batch(String sGuid, String sUser, Int16 iProcessId, String sJobName, String sParams, Int32 iRegDate, Int32 iRegTime, Int32 iSchedDate, Int32 lSchedTime, Int16 iScheduleType, String sUdl, Int32 iDependentBy, String sTimeChain, Boolean bBatchMode)

Example #2

image-20190828115452-1

File access is denied c:\...\username\batch_id_xxxxxxx\yyyyyy.cdx

Cause

There are several known causes for similar error messages:

  • Scenario #1 - Anti-virus product (running on the Controller application server) locking the temporary files
    • In one real-life customer case, the application server had McAfee anti-virus running on it.

  • Scenario #2 - Controller application server requires a restart (for example caused by a memory leak)
    • For more details, see separate IBM Technote #0730181.

Environment

Scenario #1
This has been seen (example #1) when the Controller application server has McAfee anti-virus installed on it.

Diagnosing The Problem

Obtain the VFP log file ("logvfp.log") for more information on the error.

  • TIP: For instructions, see separate IBM Technote #1373203.

    

Example #1 (Scenario #1):

In one real-life example, the log file contained the following:

COGNOS CONTROLLER Technical log - Consolidation modules
 
*****   Date: 09/03/18   Time: 13:22:40   *****
Call Stack:
1 - PROCEDURE MAIN.RUNKONSOL C:\PROGRAM FILES\IBM\COGNOS\CCR_64\SERVER\LIBS\FRANGOLIB.VCT - Line 91
2 - PROCEDURE KONSOLPS KONSOLPS.FXP - Line 594
3 - EVENTMAINS.FXP - Line 76
4 - PROCEDURE FXACQEVENTS EVENTMAINS.FXP - Line 191
5 - FXACQ2XDBS.FXP - Line 91
6 - PROCEDURE CALL_CURRCONV FXACQ2XDBS.FXP - Line 1796
7 - PROCEDURE OMRAKP OMRAKP.FXP - Line 334
8 - PROCEDURE CLOSEDB OMRAKP.FXP - Line 6518
9 - PROCEDURE FRENSA FRENSA.FXP - Line 119
10 - PROCEDURE FRENSAVFP FRENSA.FXP - Line 153
Program statement:  Not available, c:\program files\ibm\cognos\ccr_64\server\progs\frensa.prg not found
Error number: 1705
Message text: File access is denied c:\...\adm\batch_id_0000008181\fc0so8iy.dbf.

   

Example #2 (Scenario #1):

In a different real-life example (different customer), the log file contained the following:

COGNOS CONTROLLER Technical log - Consolidation modules
 
*****   Date: 06/26/19   Time: 09:03:09   *****
Call Stack:
1 - PROCEDURE MAIN.RUNKONSOL D:\PROGRAM FILES\IBM\COGNOS\CCR_64\SERVER\LIBS\FRANGOLIB.VCT - Line 91
2 - PROCEDURE KONSOLPS KONSOLPS.FXP - Line 333
3 - PROCEDURE OMRAKP OMRAKP.FXP - Line 308
4 - PROCEDURE OMRMAIN OMRAKP.FXP - Line 466
5 - PROCEDURE KURSBMK OMRAKP.FXP - Line 1977
6 - PROCEDURE INDEXTVAL1 OMRAKP.FXP - Line 4504
Program statement:  Not available, d:\program files\ibm\cognos\ccr_64\server\progs\omrakp.prg not found
Error number: 1705
Message text: File access is denied c:\...\<username>\batch_id_0000023463\fm0je7xo.cdx.

Resolving The Problem

Scenario #1 - Anti-virus product (running on the Controller application server) locking the temporary files

Reconfigure the anti-virus product (on the APP server) to exclude the folder(s) mentioned in the error message.

  

  • Example #1: In one real-life customer case, the solution was to reconfigure McAfee anti virus (running on the application server) to exclude the following folder (and subfolders):  
    • C:\Program Files\IBM\
  • Example #2: In a different real-life customer case, the solution was to reconfigure anti virus (running on the application server) to exclude the following folder (and subfolders):
    • C:\Windows\Temp\CognosController\

  

Scenario #2 - Controller application server requires a restart (for example caused by a memory leak)

Obtain a short period of downtime (no users on the system) and reboot Controller application server.

  • For more details, see separate IBM Technote #0730181.

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Document Information

Modified date:
28 August 2019

UID

ibm10730235