IBM Support

** Troubleshooting ** "Failed to register ExcelLink Addin ... Add method of AddIns class failed" error when using Excel link

Troubleshooting


Problem

User launches the 'main' Controller client (Controller 'classic'). User clicks the green 'X' button ('Controller Link'). Excel starts to launch.
  • However, an error appears.

Symptom

image 2655
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Failed to register ExcelLink Addin
Add method of AddIns class failed
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
If user clicks OK, they see:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
The Cognos Controller Link is not installed
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Cause

There are several known causes for this error:
   
  • Scenario #1 - Limitation of Controller when deployed in some (rare) locked-down environments
   
  • Scenario #2 - Client device has incompatible version of Microsoft Office installed
    • For example, using 64-bit Excel with old (incompatible) Controller 10.2.1
    • See separate IBM Technote #549767 for more details.
  
  • Scenario #3 - Some user's profiles are missing an entry in this registry key: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Excel\Options
    • Specifically, it should contain something similar to:   "OPEN"="\"C:\\Program Files\\ibm\\IBM Cognos Controller Local Client\\adxloader.Controller.ExcelLink.dll\""
    • See separate IBM Technote #6123627 for more details.
 
  • Scenario #4 - Microsoft Excel requires patching with the latest software updates.
    • See separate IBM Technote #6125067 for more details.

Environment

Scenario #1
In one real-life example, the 'bad' client device (where the Controller client was being run from) was a Citrix server which had been locked down with strict permissions (for example the Windows UAC setting was at the highest/strictest level).

Resolving The Problem

Scenario #1
Manually register the Excel add-in (for users on the client device) by adding the registry keys.
Steps:
In one real-life example, the solution was:
1. Logon to the client device (for example Citrix server) as a 'good' user (where it worked OK without an error)
  • For example, logon as a Windows administrator
2. Launch REGEDIT
3. Export the following keys to a .REG file:
  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Excel\Addins
  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Excel
For example:
image 2218
4. Populate the 'bad' end user's Windows profiles with the contents of those two .REG files
  • For example, use Active Directory to apply the registry keys to any user who logs onto that Citrix server.
   
Scenario #2
Ensure the version of MS Office is compatible with your version of Controller.
  • See separate IBM Technote #549767 for more details.
  
Scenario #3
Add the missing entry into the following registry key: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Excel\Options
  • Specifically, it should contain something similar to:   "OPEN"="\"C:\\Program Files\\ibm\\IBM Cognos Controller Local Client\\adxloader.Controller.ExcelLink.dll\""
  • See separate IBM Technote #6123627 for more details.
 
Scenario #4
Apply all the latest Microsoft Office (Excel) patches.
  • See separate IBM Technote #6125067 for more details.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
27 March 2020

UID

ibm11284004