Troubleshooting
Problem
I.T. administrator logs onto the Controller application server. Administrator launches 'Controller Configuration' and makes some changes. Administrator clicks 'save' but receives an error message.
Symptom
Typical Example:
Data was not saved!
Other Error Examples:
Failed to save changes
System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
Cause
There are several different potential causes for similar error messages:
- Scenario #1 - The user specified inside 'Specified Account' is not a member of the Controller application server's local user group "Administrators".
- Scenario #2 - User typed in incorrect username or password (for the "COM+" user)
- For more detail, see separate IBM Technote #1346588
- Scenario #3 - Controller application server has Microsoft UAC enabled.
- This is incompatible for some (older) versions of Controller.
- Scenario #4 - User currently not logged on as a Windows administrator
- Scenario #5 - The 'Controller COM+ roles and users' section is empty/blank
Environment
Scenario #3 - Controller application server based on a recent version of Microsoft Windows (for example Windows 2008 Server) which (by default) has the Microsoft feature 'UAC' enabled.
Resolving The Problem
Scenario #1 - The user specified inside 'Specified Account' is not a member of the Controller application server's local user group "Administrators".
Add the specified user account (for example 'DOMAIN\Controller_system') as a member of the Controller application server's local user group "Administrators".
Scenario #2 - User typed in incorrect username or password (for the "COM+" user)
Inside the section 'COM+ Server', make sure that you do not make any 'typo' mistakes for the username or password.
- For more detail, see separate IBM Technote #1346588
Scenario #3 - Controller application server has Microsoft UAC enabled.
This is incompatible for some (older) versions of Controller.
Workaround
When you launch Controller Configuration, make sure that you "right click" on the icon, and choose "Run as administrator"
Fix:
Disable UAC by performing the following:
1. Obtain a short period of downtime (no users on Controller)
2. Logon to the application server
3. Click "Start - Settings - Control Panel"
4. Click "User Accounts- User Accounts"
5. Click "Change User Account Control settings"
6. Change slider setting to "Never notify"
7. Click OK
8. Afterwards, reboot the application server (for the UAC to take effect)
Scenario #4 - User currently not logged on as a Windows administrator
Logoff from Windows (on the Controller application server). Re-logon to Windows as a Windows user who is a member of the local 'Administrators' group.
Scenario #5 - The 'Controller COM+ roles and users' section is empty/blank
On the Controller application server:
1. Launch Controller Configuration
2. Open the section 'COM+ Server'
3. In the Controller COM+ roles and users, click in the area, and then click the New (‘white page’) button from the main tool bar
4. In the COM+ Role, enter a suitable name, such as “ControllerUsers”
5. In the COM+ User, enter: everyone
6. Repeat the three previous steps, but enter the user: NT AUTHORITY\SYSTEM
Related Information
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Document Information
Modified date:
30 August 2019
UID
swg21468207