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** Troubleshooting ** 'Controller' Excel link (COM Add-in) disappears each time that Excel is closed / relaunched

Troubleshooting


Problem

Each time the user closes and re-launches Excel, the menu item 'Controller' disappears.
Problem typically only affects one/some user(s).

Symptom

Main Symptom
User launches Excel. User notices that the 'Controller' menu item is not visible:

User opens the 'COM Add-Ins' menu item, and ticks "Cognos Controller Link for Microsoft Excel".

  • This enables the Controller menu item (temporary workaround):

However, if the user closes Excel and then reopens Excel, the menu item disappears again.

Secondary Symptom

In some environments, if a user presses F9 (to refresh/run a report) then they get the following error:

The type initializer for 'XLLContainer' threw an exception

Cause

There are several known causes for this symptom:
  
  • Scenario #1 - 'Bad' end user's Windows user profile is configured to not enable the COM+ add-in during Excel startup
    • Specifically, the registry key 'HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\Controller.ExcelLink.AddinModule' contains the wrong value for the entry 'LoadBehavior'
    • TIP: For more details, see separate IBM Technote #1991705.
 
  • Scenario #2 - Problem with shared Terminal Server device, triggered by 'bad' end users not having Windows administrative rights to the server
    • In some rare circumstances, this can cause some (but not all) of the non-admin users (on the Terminal Server) to get this issue.

Resolving The Problem

Fix:
  
Scenario #1
Modify the registry to configure the Controller COM+ add-in to automatically load (when Excel starts).
  • The correct value should be '3' (which means "Loaded at Startup")
  • TIP: For more details, see separate IBM Technote #1991705.
   
Scenario #2
Ask a Windows administrator (for example an I.T. department member, who has Windows administrative rights) to logon to the client device (for example Citrix/Terminal Server).
  • Ask them to perform the steps to manually add the Controller COM add-in.
  • From now onwards, all 'bad' users (who share the same Citrix/Terminal Server) should be able to always see the add-in.
   
Workaround
Temporarily enable the add-in (each time that Excel is launched).
Steps:

The steps vary slightly depending on the Excel version. The below steps are based on Excel 2013:

1. Launch Microsoft Excel

2. Click "File - Options":

3. Click section ' Add-ins':

4. Ensure that ' Manage' is set to ' COM Add-ins', and click 'Go':

5. Tick the box 'Cognos Controller Link for Microsoft Excel'

6. Click OK
7. Test.

Document Location

Worldwide

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Document Information

Modified date:
17 February 2019

UID

ibm10872066