IBM Support

** Troubleshooting ** "Cannot run the macro 'cc.CompareDb'. The macro may not..." when launch Excel via the Controller Excel link button

Troubleshooting


Problem

User launches the main Controller client (CCR.EXE). User clicks the green 'X' (to launch the Controller link). Excel starts to load. After a few seconds, an error appears.

Symptom

The error will vary slightly depending on version of Controller.

Example #1 (Controller 10.4.2):

image 4754

Error Launching menu item "Controller Link"

Cannot run the macro 'cc.CompareDb'. The macro may not be available in this workbook or all macros may be disabled.
at Microsoft.VisualBasic.CompilerServices.LateBinding.LateGet(Object o, Type objType, String name, Object[] args, String[] paramnames, Boolean[] CopyBack)
at Microsoft.VisualBasic.CompilerServices.NewLateBinding.LateGet(Object Instance, Type Type, String MemberName, Object[] Arguments, String[] ArgumentNames, Type[] TypeArguments, Boolean[] CopyBack)
at Cognos.Controller.Forms.Common.fFrmFrangoFunc.RunExcelMacro(Object xlApp, Object& macro, Object[] args)
at Cognos.Controller.Forms.Common.fFrmFrangoFunc.InitExcelLink(Object& xlApp, String sText, Int32 excelProcessId)
at Cognos.Controller.Forms.ControllerMDI.DoAction(Int32 iMenuIDNumber, ControllerMenuItem ClickedItem)

Example #2 (Controller 10.2.1):


Error Details
Cannot run the macro 'cc.CompareDb'. The macro may not be available in this workbook or all macros may be disabled.

Cause

There are several possible causes for this error:

  • Scenario #1 - Invalid/corrupt installation of Microsoft Office installed on the client device.
    • In one real-life customer example, the problem occurred on a Citrix server which had previously been successfully running Controller 10.1.1. The customer added Microsoft Powerpoint (to the existing MS Office installation) and then immediately afterwards tried to upgrade the Controller client to 10.2.1 FP2. The error occurred.
  • Scenario #2 - The client device (for example user's laptop) has an unsupported version of Microsoft Office installed
    • In one real-life example, customer was using Controller 10.2.1 (which is no longer supported by IBM) but they had a 64-bit version of Microsoft Office installed on the client device. Controller 10.2.1 did not support 64-bit Excel. For more details, see separate IBM Technote #1971871
    • In a different real-life example, customer was using Controller 10.4.2, and they had an old (out of date) build of 32-bit Office 365 installed on the client device. Controller 10.4.2 works OK using 32-bit Office 365 so long as it has the latest Microsoft patches installed. Alternatively you can use 64-bit Excel. For more details, see separate IBM Technote #1282036
  • Scenario #3 - The Controller client has not registered correctly.
    • For more details, see separate IBM Technote #1973528
  • Scenario #4 - Required Microsoft Office components are not installed (on the client device).
    • In one real-life example, the end user's device did not have the following Office 2010 component installed: Office Shared Features\Visual Basic for Applications
    • For more details, see separate IBM Technote #1981002
  • Scenario #5 - The client device has (mistakenly) got multiple different versions of the Controller client installed.
    • For more details, see separate IBM Technote #571703
  • Scenario #6 - There is a 'stuck' (hung / crashed) session of Excel (running on the client device) which needs to be closed down.
    • For more details, see separate IBM Technote #0735329

Resolving The Problem

Scenario #1 - [Invalid/corrupt installation of Microsoft Office installed on the client device]
In one real-life customer example (where the problem occurred on a Citrix server which had recently had PowerPoint added to an existing MS Excel installation), the solution was to perform the following on the client device (the Citrix server):

1. Uninstall Controller client
2. Uninstall Microsoft Office completely
3. Install Microsoft Office
4. Apply all the latest Microsoft Office patches (as a precaution)
5. Install the Controller client.

 
Scenario #2 - [The client device has an unsupported version of Microsoft Office installed].

  • Example #1 (Controller 10.2.1): Uninstall Microsoft Office 64-bit from the client device, and then install Microsoft Office 32-bitFor more details, see separate IBM Technote #1971871
  • Example #3 (Controller 10.4.2): Either patch your existing 32-bit Excel to the latest version, or change to using 64-bit. For more details, see separate IBM Technote #1282036

 
Scenario #3 - [The Controller client has not registered correctly].
Register the Controller Excel/COM add-ins manually (inside Excel) correctly.

  • For more details, see separate IBM Technote #1973528

 
Scenario #4 - [Required Microsoft Office components are not installed (on the client device)].

Modify the end user's client device so that the required features (for example 'Office Shared Features\Visual Basic for Applications') are enabled/installed/registered.

  • For more details, see separate IBM Technote #1981002

Scenario #5 - [The client device has (mistakenly) got multiple different versions of the Controller client installed].

Ensure that only one version of the Controller client is installed..

  • For more details, see separate IBM Technote #571703

 
Scenario #6 - [There is a 'stuck' (hung / crashed) session of Excel (running on the client device) which needs to be closed down].

Close all instances of Microsoft Excel, running on the 'bad' client device. Then re-try.

  • For more details, see separate IBM Technote #0735329

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
29 June 2020

UID

swg21971878