IBM Support

Troubleshooting API Connect Analytics - Analytics running out of disk space

Troubleshooting


Problem

Analytics running out of disk space

Symptom

No disk space

Cause

Analytics indices taking up too much space

Resolving The Problem

Look at all indices :

curl_es _cat/indices?v

Find the old and large indices that can be deleted and delete them using:

curl_es -XDELETE <index_name>

Reduce the retention period from the Cloud manager:

Topology -> Analytics Service -> Advanced analytics configuration -> Storage:

Oldest Api Call Data Kept -

Set this to the lowest possible value (default is 90 days)

Another option for reducing the index size is by excluding large fields like response_body from being saved in the index:

filter {

  if "apicapievent" in [tags] {

     mutate {

            remove_field => ["response_body"]

        }

  }

}

You can follow instructions here on how to filter response_body:

For 2018:

https://www.ibm.com/docs/en/api-connect/2018.x?topic=filters-sample-customizing-analytics-data

For v10:

https://www.ibm.com/docs/en/api-connect/10.0.x?topic=subsystem-modifying-your-analytics-data

Also, make sure the index is rotating as scheduled:

Check the rotation time and number of documents to meet your requirement:

Topology -> Analytics Service -> Advanced analytics configuration -> Storage:

Index Roll Over -> Max age and Max Documents

Check the retention and rollover jobs are running by checking the age of the job and the logs to see whether there is any issue:

oc get jobs

NAME                                                 COMPLETIONS   DURATION   AGE

analyt-cj-retention-1632965400                     1/1           17s        21h

analyt-cj-rollover-1633040100                        1/1           10s        15m

Document Location

Worldwide

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Document Information

Modified date:
18 October 2021

UID

ibm16496811