IBM Support

Troubleshooting Access Client Solutions error MSGGEN003 (Not able to pass connection to server job)

Troubleshooting


Problem

Connecting with IBM i Access Client Solutions (ACS) fails and results in the error MSGGEN003- An Input/Output error occurred. (Not able to pass connection to server job.) New connections are not able to pass through the IBM i Host Server jobs. 

Symptom

Users connecting with ACS are unable to connect. May affect any feature of ACS ( 5250 emulator, Data Transfer, Run SQL Scripts, etc.)

Cause

This error indicates an issue with one of the IBM i Host Server jobs passing incoming connections to the next server job. Causes tend to vary. 

Known causes:
- Host Server job failing to start successfully.
- A missing Subsystem has not been started. 
- Custom Subsystem Routing is causing an issue. 
- Exit point program is blocking host server processing. 
- Various Authority issues. Most likely after a system restore has been processed. 
- QYSMSVRE user index is corrupted. 

Environment

All versions of ACS. 

Diagnosing The Problem

  • Gathering the ACS service logs will help pinpoint which IBM i Host Server is having issues. Also gathering a Trace Connection(TRCCNN Instructions) of a re-create will also show where the connection is failing. 
  • Gathering a Job Trace on the host server jobs will show helpful information. Follow the STRTRC steps (STRTRC- Starting a Job Trace Job ) to capture a job trace of both the Daemon and Server jobs from the Host Server in question. Start the Job Traces before the re-create of the issue. 
  • If a Restore was just performed, using RSTAUT may correct any authority issues. 
  • The QYSMSVRE index that host servers rely on may be corrupt.
  • Investigation of the IBM i Host Server's job logs will show any errors occurring with the Host Server. Host servers and their corresponding jobs are as follows. Investigate both the Daemon and Server job logs. 
*CENTRAL: The central server daemon is started in the QSYSWRK subsystem. The daemon job is named QZSCSRVSD. The associated server job is named QZSCSRVS.
*DATABASE: The database server daemon is started in the QSERVER subsystem. The daemon job is named QZDASRVSD. The associated server jobs are named QZDASOINIT, QZDASSINIT, and QTFPJTCP.
*DTAQ: The data queue server daemon is started in the QSYSWRK subsystem. The daemon job is named QZHQSRVD. The associated server job is named QZHQSSRV.
*FILE: The file server daemon is started in the QSERVER subsystem. The daemon job is named QPWFSERVSD. The associated server jobs are named QPWFSERVSO, QPWFSERVSS, and QPWFSERVS2.
*NETPRT: The network print server daemon is started in the QSYSWRK subsystem. The daemon job is named QNPSERVD. The associated server jobs are named QNPSERVS and QIWVPPJT.
*RMTCMD: The remote command and distributed program call server daemon is started in the QSYSWRK subsystem. The daemon job is named QZRCSRVSD. The associated server job is named QZRCSRVS.
*SIGNON: The signon server daemon is started in the QSYSWRK subsystem. The daemon job is named QZSOSGND. The associated server job is named QZSOSIGN.
*SVRMAP: The server mapper daemon is started in the QSYSWRK subsystem. The daemon job is named QZSOSMAPD.

Resolving The Problem

There is no exact resolution to this specific error as it may be caused by various reasons. Use the tools provided above to further investigate the issue and find actual cause. 

Document Location

Worldwide


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Document Information

More support for:
IBM i Access Client Solutions

Software version:
All Version(s)

Document number:
6334283

Modified date:
20 June 2022

UID

ibm16334283

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