Troubleshooting
Problem
After upgrading to Platform 3.5.1 of IBM TRIRIGA, the BIRT reports throw a stack error and fail to run. When observing closely, there is an extra location root in front of the full qualified path (example: C:/tririga_install/userfiles/C:\tririga_install\userfiles\birt\resources\reportABC.rptdesign).
Cause
This is a code error in the platform. It was logged in the 3.5.1.1 product release notes under defect 229997.
Diagnosing The Problem
- Login to TRIRIGA
- Go to Report Manager, System Reports
- Select a BIRT report and run it.
The report should fail, printing in the screen a stack trace error.
*Server root was obfuscated.
Resolving The Problem
This has been fixed in FixPack 1 for 3.5.1, available in IBM Fix Central.
Related Information
[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IBM TRIRIGA Application Platform Runtime Engine","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"3.5.1","Edition":"Edition Independent","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
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Document Information
Modified date:
17 June 2018
UID
swg21989591