IBM Support

TM1 Server is hanging, not responding, and tm1server.log is full of TM1.Event mt_WaitForSingleObject: Timed out on event 0x0x2788d60

Troubleshooting


Problem

TM1 Server is hanging, not responding, and tm1server.log is full of these messages:
TM1.Event    mt_WaitForSingleObject: Timed out on event 0x0x2788d60

Cause

Too many events to handle, caused by "Top*" parameters in tm1s.cfg, or by too many DEBUG levels in tm1s-log.properties

Resolving The Problem

-In tm1s.cfg, comment all "Top*" parameters like this:
# TopLogging=T
# TopScanFrequency=15
# TopScanMode.Sandboxes=T
These parameters can cause such an issue on some large models.
Instead, use the tm1top tool as described in these other documents:
-In tm1s-log.properties, some loggers are more verbose than others, and setting too many loggers might lead to this kind of issue.
Verify there are not too many loggers set to DEBUG.
Verify the highest level is not in DEBUG mode, meaning: "log4j.logger.TM1=DEBUG" must be avoided at all costs.
-If these messages are caused by another issue that requires some time to be fixed, then these messages can be temporarily disabled by adding this line in tm1s-log.properties:
log4j.logger.TM1.Event=OFF

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m3p000000PC9VAAW","label":"Planning Analytics-\u003EServer Data Tier-\u003ELogging"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]

Document Information

Modified date:
16 November 2022

UID

ibm16839779