IBM Support

TM1 Application does not appear in TM1 Applications list after deployment

Troubleshooting


Problem

After deploying an application from Performance Modeler the application does not appear in the application list of the TM1 Applications web portal. The administration icon on the TM1 Applications web portal is also missing even if the user is in the ADMIN group in TM1. No error message was displayed during deployment. If using CAM authentication the application can be seen in the Cognos BI IBM Cognos TM1 Applications - My Application folder.

Cause

This problem may occur after applying a Fixpack to the TM1 Applications installation.

Or

Changing TM1 Security Modes.

Resolving The Problem

1 - Stop the IBM Cognos TM1 Applications service
2 - Delete your ..\tm1_64\tomcat\work\catalina\localhost\pmpsvc
directory
3 - Edit the ..\tm1_64\webapps\pmpsvc\WEB-INF\configuration\fpmsvc_config.xml file. Delete all content between (but not including) the <tm1> and </tm1> xml tags and save the file.
***If the fpmsvc_config.xml.new file exists, you can also backup/replace the existing fpmsvc_config.xml file with this one.
4 - Start the IBM Cognos TM1 Applications service
5 - Clear your web browser cookies and cache
6 - Browse back to the TM1 Applications web portal and complete the initialization page (select a TM1 server).

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21695143