Troubleshooting
Problem
TM1 API / TM1 SDK / TM1 REST API / tm1runti.exe cannot access to Cognos BI Server namespace (CAM security) Messages in tm1server.log : TM1.API.Return.Error RetError: SystemServerClientNotFound TM1.Login Login Error: SystemServerConnectWithCAMNamespace failed
Cause
- tm1web.html incorrect
or
- missing valid domains in CAF configuration
or
- IBM Cognos service account does not have the required rights.
Resolving The Problem
- If some of these messages are found in cogserver.log :
Invalid URL domain or host: host port => YourServerName:9510
invalid value: decoded value => http://YourServerName:9510/tm1web
URL does not match any valid domain or host:
valid domains => validExactDomains=[] validHighLevelDomains=[]
invalid variable: value => http://YourServerName:9510/tm1web
URL does not match any valid domain or host:
valid hosts =>[ list of valid hosts ]
is valid URL failed: URL => http://YourServerName:9510/tm1web
Then add YourServerName and http://YourServerName:9510/tm1web in the list of valid hosts and domains for the CAF (IBM Cognos Application Firewall in Cognos Configuration)
And update tm1web.html to add http://YourServerName:9510 in the tm1webServices variable
(tm1web.html should be placed in C:\Program Files\ibm\cognos\c10_64\webcontent\tm1\web on the Cognos BI installation)
- Verify that the account used to start "IBM Cognos" service has the following permissions (in Windows Administration Tools, Local Security Policy, Local Policies, User Rights Assignment) :
Act as part of the operating system
Log on as a service
In addition to this, this account should be part of the local "Administrators" group of the machine. This is mandatory.
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Document Information
Modified date:
15 June 2018
UID
swg21958957