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Time zone, clock, date formats for Controller - explanation and description

Troubleshooting


Problem

User uses the Controller client functionality. When they look at the timestamp of some of the values they look different from expected.
  • In addition, sometimes the date format is not as expected.
Where does the Controller client gets is clock/time-zone/date format settings from?

Symptom

There are many different places where the date/time is shown, for example:
(1) Batch queue
image-20190429111950-1
(2) Data Entry - Company Journals
image-20190429112501-1
(3) Standard Reports
image-20190429112638-1

Cause

The Controller system collects/displays the clock/time from different sources, depending on the functionality being used:
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(1) Batch queue
When a job is created with the "Perform This Job" setting set to be "Execute Immediately" then the values shown inside "View Batch Queue" come from the following places:
  • Started - the time according to the Controller database server
  • Ended - the time according to the Controller database server
  • Reg Time - Time as seen in the 'Schedule job' at area of the Schedule Job dialogue box (according to the client machine of the user creating the batch job)
  • Scheduled Time - the time according to the Controller application server
TIP: For more information on the above (plus information if the job is scheduled - not executed immedately) see separate IBM Technote #1590788.
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(2) Data Entry - Company Journals
The values inside 'Created' and 'Last Modified':
  • Are based on the time of the Controller application server
    • Therefore if the clock of the application server is 10 minutes fast, then all users will see the entries displayed as 10 minutes different from what they expect.
  • However, it is adjusted by (relative to) the time-zone of the client device
    • Therefore a user in the same time zone as the application server will see the time displayed as the same as the application server
    • A user in a time zone one hour ahead will see the time correct for their time zone (in other words, one hour ahead)
  • Display using the date format of the client device's Windows regional settings.
For example a US user whose client device's Windows clock looks like this...
image-20190429140125-1
     ...will see the date 29th April 2019 displayed as:   4/29/2019:
image-20190429140140-2
For example a UK user whose Windows clock looks like this...
image-20190429140319-4
     ...will see the date 29th April 2019 displayed as:   29/4/2019:
image-20190429140332-5
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(3) Standard Reports
The date/time shown on all standard reports is the date/time of the Cognos Analytics (previously known as 'Cognos BI') report server.
  • In other words, it is the date/time of the server specified inside the 'Report Server' section (of Controller Configuration):
image-20190429134201-1
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Environment

Example:
Imagine a scenario where:
  • Customer using Controller-on-Cloud 10.3.1
  • Citrix/APP/database servers all using Windows time zone set to UTC
  • End user based in British Summer Time (UTC+1)
In the above scenario, the batch jobs will appear (in the queue) using times which are 1 hour earlier than the user.
  • For example, if the end user creates a job at 12:37 pm, then (inside the queue) it will appear to be scheduled for 11:37 am.

Resolving The Problem

This behaviour is by design.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
29 April 2019

UID

ibm10882848