IBM Support

Thick client will not load with Oracle Java version

Troubleshooting


Problem

The Control Center thick client option from the web console will not load if the installed version of Java on the workstation is at the following: java -version java version "1.8.0_141" Java(TM) SE Runtime Environment (build 1.8.0_141-b15) Java HotSpot(TM) 64-Bit Server VM (build 25.141-b15, mixed mode) works on this version C:\Users\p1pmlq1>java -version java version "1.8.0_73" Java(TM) SE Runtime Environment (build 1.8.0_73-b02) Java HotSpot(TM) 64-Bit Server VM (build 25.73-b02, mixed mode)

Cause

There is a problem with the JRE
"Java(TM) SE Runtime Environment (build 1.8.0_141-b15)". The
description of the bug is "Behavioural change in 8u141 is causing some
jar files to fail verification."

Environment

IBM Control Center 6.1.0.1
java -version
java version "1.8.0_141"
Java(TM) SE Runtime Environment (build 1.8.0_141-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.141-b15, mixed mode)

Resolving The Problem

There is a problem with the JRE "Java(TM) SE Runtime Environment (build 1.8.0_141-b15)". The description of the bug is "Behavioural change in 8u141 is causing some jar files to fail verification." In order to get around the failure you will need to either go back a release of the JRE or go forward to at
least release 1.8.0_144-b01 (released July 26, 2017).

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.0.0.1;6.1.0.1","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg22008089