Troubleshooting
Problem
User clicks 'Perspectives' (on the Start menu). User receives an error.
Symptom
C:\Program Files\ibm\cognos\tm1_64\bin\tm1p.xla
There was a problem sending the command to the program.
Cause
Perspectives Excel add-in is not correctly registered (inside Excel).
Environment
In one real-life example:
- Problem occurred on the 64-bit application server
- It had a 32-bit version of Excel 2016 installed.
Resolving The Problem
Manually register the TM1 add-in in Excel.
Steps:
1. Launch Excel
- TIP: In one real-life environment, this had to be done by right-clicking on the Excel icon, and choosing 'Run as Administrator'.
2. Click "File - Options"
3. Open the 'Add-ins' section
4. Ensure 'Manage' is set to 'Excel Add-ins' and click 'Go'
5. Browse to add the relevant file, for example: C:\Program Files\ibm\cognos\tm1_64\bin\tm1p.xla
[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Perspectives","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 June 2018
UID
swg22006088