Troubleshooting
Problem
Testing a datasource in Administration Console fails with
Proxy Error
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /ibmcognos/bi/v1/disp.
Reason: Error reading from remote server
Symptom
Proxy Error
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /ibmcognos/bi/v1/disp.
Reason: Error reading from remote server
Cause
Testing the datasource takes longer than the defined timeout on Apache Webserver.
Environment
IBM Cognos Analytics with Gateway installation
Apache 2.2 or 2.4 as Webserver
Resolving The Problem
In the Apache Webserver configuration (ie. cognos.conf) increase or set the TimeOut parameter.
By default the TimeOut is set to 60 seconds.
Example:
KeepAliveTimeout 5
TimeOut 120
TimeOut 120
A restart of Apache Webserver is required after saving the changed configuration.
For more information refer to the Apache Webserver documentation: https://httpd.apache.org/docs/2.4/en/mod/core.html#timeout
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
28 May 2019
UID
ibm10885867