IBM Support

TEST Request Sent When Automatically Ordering PTFs Fails

Troubleshooting


Problem

Starting at OS V7R3, there is new function to order PTFs automatically (ORDPTFAUTO). If this function fails, the process is designed to send a TEST request to verify the connection to IBM backend systems.

Symptom

IBM hardware field representative (SSR/CE) contacts client in response to TEST request, though neither know why the request was sent.

Cause

The /QIBM/UserData/OS400/UniversalConnection/eccConnect.properties file contains an incorrect URL, causing intermittent failures when ordering PTFs.

Environment

Diagnosing The Problem

Check the scheduled time of the QORDPTFGRP job schedule entry and compare it to the time of the TEST request received. If the time of the TEST request is the same time as the QORDPTFGRP scheduled job runs, it is likely the process has failed. Use WRKJOBSCDE JOB(QORDPTFGRP) to see the scheduled time for the job. Review the QORDPTFGRP job log for errors.

Resolving The Problem

The new function to order PTFs automatically is configured in the Service Attributes (CHGSRVA). When Order PTFs automatically (ORDPTFAUTO) is set to *YES, a job schedule entry named QORDPTFGRP is created. If the process of this scheduled job fails, a TEST request is sent to check the connection to the IBM systems. Additional information about this function could be found on Automatic ordering of PTF groups link.

In one instance, all of the PTFs in the cumulative and group PTFs that were being ordered were already applied to the system. The QORDPTFGRP job log showed that all of the PTFs were already applied or for a product not installed on the system. Though the process should have been successful, it was logging a failure and the TEST request was being sent.

It was found that the URL in the _IBM.SP_LOCATION_URL= parameter in the /QIBM/UserData/OS400/UniversalConnection/eccConnect.properties file was incorrect.

The value should be:

_IBM.SP_LOCATION_URL=https\://esupport.ibm.com/eccedge/gateway/services/projects/ecc/serviceProviderIBMV2.gzip

To resolve the issue, do one of the following steps while signed on with a user profile that has *SECOFR authority:

Option 1: Delete and Recreate the Service Configuration

Option 2: Manually Update the _IBM.SP_LOCATION_URL= Parameter

Manually update the _IBM.SP_LOCATION_URL= parameter, delete the serviceProviderIBMLocationDefintion* files from the UniversalConnection directory and copy the serviceProviderIBM.xml file from ProdData to the UserData directory path.

A) Manually edit the URL for the _IBM.SP_LOCATION_URL= parameter in the eccConnect.properties file:

WRKLNK '/QIBM/UserData/OS400/UniversalConnection/*'
Locate the eccConnect.properties file and select option 2=Edit
NOTE: There may be two files that begin with eccConnect.properties. Use F22=Display entire field to see the complete file name. The second file may have a .lck extension and the file will be empty. Do not update this file.

Locate the line that contains _IBM.SP_LOCATION_URL= and update the value to be: _IBM.SP_LOCATION_URL=https\://esupport.ibm.com/eccedge/gateway/services/projects/ecc/serviceProviderIBMV2.gzip

Press F3=Save/Exit twice

B) Delete all files that begin with serviceProviderIBMLocationDefinition*
Locate the files named serviceProviderIBMLocationDefinition files and delete (4=Remove) all files:
NOTE: Use F22=Display entire field to see the complete file name.
serviceProviderIBMLocationDefinition.bak
serviceProviderIBMLocationDefinition.lck
serviceProviderIBMLocationDefinition.txt
serviceProviderIBMLocationDefinition.xml



C) Copy the serviceProviderIBM.xml from the /QIBM/ProdData/OS400/UniversalConnection directory to the /QIBM/UserData/OS400/UniversalConnection directory:

CPY OBJ('/QIBM/ProdData/OS400/UniversalConnection/serviceProviderIBM.xml') TODIR('/QIBM/UserData/OS400/UniversalConnection') OWNER(*KEEP)

Test ordering the cumulative or group PTFs.




After performing option 1 or 2, test ordering the cumulative or a group PTF to verify the function is successful. Review the interactive joblog for errors. For example, to order the cumulative:
SNDPTFORD PTFID((SF99730)) -or- SNDPTFORD PTFID((*CUMPKG))


If the failure continues, collect the QORDPTFGRP job log and  collect additional information using QMGTOOLS. Check QMGTOOLS: Collect ECS/ESA data document for instructions.

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0"}]

Document Information

Modified date:
17 February 2020

UID

nas8N1021921