IBM Support

Technician application fails to download work when using HTTP Server

Troubleshooting


Problem

When using the IBM HTTP Server the Maximo Mobile application the worklist fails to download for technician.

Cause

This is caused by the length of the query sent from the device to Maximo exceeding the maximum number of characters defined for  LimitRequestFieldSize and LimitRequestLine.

Diagnosing The Problem

Review the IBM HTTP Server access logs or the Maximo Mobile device logs and you should see a response with the following error.
"Request-URI Too Long"

Resolving The Problem

Open your IHS httpd.conf file, and update the LimitRequestFieldSize property and the LimitRequestLine property to 50000.
 
For example:
<VirtualHost *:443>
SSLEnable
SSLClientAuth None
SSLProtocolDisable SSLv3 SSLv2
LimitRequestFieldSize 50000
LimitRequestLine 50000
 
After you update both properties, save the httpd.conf file, and restart the IHS server.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAgaAAE","label":"Maximo Application Suite->MAS Applications->Mobile"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.5.0"}]

Document Information

Modified date:
11 August 2021

UID

ibm16480349