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Objective of This Unit

Useful Techdoc ...

https://www.jcp.org/en/jsr/detail?id=352

This is based on the JSR-352 Specification, which can be found here:

Okay, I understand the key 
concepts and can carry on a 

conversation with developers public class SleepyBatchlet extends AbstractBatchlet {

    private final static Logger logger = Logger.getLogger(SleepyBatchlet.class.getName());

    /**
     * Logging helper.
     */
    protected static void log(String method, Object msg) {
        System.out.println("SleepyBatchlet: " + method + ": " + String.valueOf(msg));
        // logger.info("SleepyBatchlet: " + method + ": " + String.valueOf(msg));
    }

I'm going deep into 
Java coding ...

https://www.jcp.org/en/jsr/detail?id=352
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A Very Useful Document

The standard specification ...

http://www.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/WP102706

This document explains the concepts 
and some of the details of the JSR-352 
specification.

http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/WP102706
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JSR-352 is a Standard, Which Means Programs Written to the Standard are Portable

Overview ...

Java Batch application written to 
the JSR-352 interface specification

JSR-352
Compliant
Windows

JSR-352
Compliant
Windows

JSR-352
Compliant

UNIX

JSR-352
Compliant

UNIX

JSR-352
Compliant

Linux

JSR-352
Compliant

Linux

JSR-352
Compliant

z/OS

JSR-352
Compliant

z/OS

JSR-352
Standard

IBM Operational 
Enhancements

The things you'll learn about in this workshop are nearly all IBM 
operational enhancements built around the core JSR-352 standard

● The jobOperator implementation: REST interface, batchManager, batchManagerZos
● Job logging, batch events, z/OS SMF records, multi-JVM design, etc.

The application has no direct awareness of any of that.  The code has no 
specific requirement needed to use any of that.
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JSR-352 OverviewJSR-352 Overview



  

6

IBM WebSphere Liberty Batch z/OS

© 2017 IBM Corporation

Our Picture from Unit 1 - Overview

Key terminology ...

"Job Operator""Job Operator"

"Job Repository""Job Repository"

"Job Specification Language (JSL)""Job Specification Language (JSL)"

XML

"Chunk Step""Chunk Step"

"Batchlet Step""Batchlet Step"

JSR-352 
Java Batch 
Program

1
2

3
4

5

1. Java Batch Program
You write this based on the defined JSR-352 requirements.  
This is packaged as a servlet (WAR) and deployed into Liberty 
just like any other application would be deployed.

2. Job Step Programming Types
Two job step types defined:
Chunk: the looping model we most often associate with 
batch processing.  This includes functions such as 
checkpointing, commits and rollbacks, and job restarts.
Batchlet: a simple "invoke and it runs" model.  This is useful 
for non-looping functions such as file FTP steps.

3. Job Specification Language (JSL)
An XML specification to describe the batch job: the steps, the 
Java programs that implement the steps, and the flow of 
steps within the job.

4. Job Operator
This interface defines how to submit and control 
jobs.  This workshop focuses on the IBM 
enhancements around this job operator definition.

5. Job Repository
The specification calls for a repository to track job 
submissions and results, but leaves it to the vendor 
to implement.  We'll use IBM DB2 z/OS in workshop.  

Unit 3Unit 3
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Job "Instance"
Runtime assigns an ID #

For example: "Instance.11"

Job "Execution"
Runtime assigns an ID #

Ex: "Execution.11"

Job "Execution"
Runtime assigns an ID #

Ex: "Execution.12"

Stopped or Failed?
Then restart ...

4

5

Some Key Terminology from the JSR-352 Specification

Job Step Types ...

Job Step
Performs some work

Job Step
Performs some work

Job Step
Performs some work

Job Step
Performs some work

Job Step
Performs some work

Job Step
Performs some work

Job

XMLXML Job Specification Language (JSL)

Started

1

2

3

1. Job
A "job" encapsulates all the artifacts of a given batch 
process.  

2. Job Step
A "step" implements a particular portion of your batch job. 
 Your job may have 1 to many steps.

3. JSL
The Job Specification Language describes the components 
of the job, and defines the flow of execution (called 
"orchestration").

4. Job Instance
When a job is started, a "job instance" is created and 
assigned an instance ID.

5. Job Execution
Within a job instance a "job execution" is created and is assigned an execution ID.  Under 
normal circumstances the execution and instance complete and the job completes.  But if 
the job execution is stopped or failed, then you can restart within the same job instance.  A 
new "job execution" is created.
If your job completes successfully and you start it again some time later, it gets a new Job 
Instance ID and a new Job Execution ID.
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Two Step Types – Batchlet and Chunk

Batchlet code stub example ...

"Batchlet"

Start

End

process()
Your business logic processing is done here

This may contain whatever you require to 
implement the processing for this job step 
operation.

stop()
Spec says a well-behaved Batchlet will 
respond to stop() from the JobOperator

"Chunk"

ItemReader
readItem()

Implement the data read activity here.  It 
reads one data "record" at a time.

ItemProcessor
processItem()

Implement the data process activity here.  
This acts upon the data object passed to it 
by the ItemReader.

ItemWriter
writeItems()

Implement the data write activity here.  
This writes the set of data objects passed 
to it at checkpoint or end-of-data.

Start

End
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Example: Batchlet Step Outline Generated by WDT Tooling

Overview of chunk processing ...

package com.ibm.test;
import javax.batch.api.Batchlet;
public class MyBatchlet implements Batchlet {

    /**
     * Default constructor. 
     */
    public MyBatchlet() {
        // TODO Auto-generated constructor stub
    }

/**
     * @see Batchlet#stop()
     */
    public void stop() {
        // TODO Auto-generated method stub
    }

/**
     * @see Batchlet#process()
     */
    public String process() {
        // TODO Auto-generated method stub
return null;
    }
}

The IBM WebSphere Development Tool (WDT) 
plugin to Eclipse has code to support JSR-352 
programming.

This is what the a batchlet step looks like when it's 
first generated.

Your batchlet step code goes here

Your batchlet stop processing code goes here

The code for ItemReader, ItemProcessor, and 
ItemWriter is similar … but a bit longer and with 
more methods as per the spec requirements
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Overview of Chunk Processing

Chunk checkpoint control ...

StartStart

readItem()readItem()

processItem()processItem()

Ckpt?Ckpt?

writeItems()writeItems()

EOR?EOR?

EndEnd

Null?Null?

COMMITCOMMIT

1

2

3

1. The Read / Process loop
This loop processes until either a checkpoint interval is met (more on this coming up), or 
the reader returns a null, which means end-of-records.
The item returned from processItem() is added to a list of items which is eventually 
passed to the ItemWriter and written.

2. The Checkpoint / Write loop
If a checkpoint interval is reached (more on this coming up), control goes to the 
ItemWriter.  The container passes the ItemWriter a list of items to write.  Here your code 
may either iterate through the list, or perform a bulk insert if the output data resource 
permits that.  At this point a transactional commit is processed if data resource supports 
transactional context. 

3. The End of Records final write and exit
At some point you'll run out of records your ItemReader reads from, and that will trigger 
a final call to the ItemWriter and a final commit.

Some detail not shown:
● The open() method in both the ItemReader and the ItemWriter, which the container calls at the start
● The close() method in both the ItemReader and the ItemWriter, which the container calls at the end
● The checkpointInfo() method of both ItemReader and ItemWriter, which is used to maintain information 

about where within the records the last read and write was accomplished
● The transaction wrapper maintained by the container for transactional resources

List

No

Yes

No

Yes

Yes
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Chunk Step Checkpoint Control

Status Codes ...

<chunk 
  checkpoint-policy="{item|custom}" 
  item-count="{value}" 
  time-limit="{value}" 
  skip-limit="{value}" 
  retry-limit="{value}" /> 

Java EE Runtime Server
Liberty z/OS for this Workshop

Java Batch "Container"
Application
<chunk step>

JSLJSL Job Specification File

1

2

3

4

Your chunk code does not handle iterative looping, and does not do 
checkpoint processing.  That is the role of the Batch Container.
Batchlet steps are another matter … if you're looping in there, that's up to you.

1. The "batch container"
This is the JSR-352 implementation inside the Java EE 7 runtime.

2. checkpoint-policy
This is defined on the <chunk> element of the JSL, and you may either 
specify "item" (container handles) or "custom" (your own code handles)

3. item-count and time-limit
"item-count" specifies the number of iterations of ItemReader / 
ItemProcessor for a checkpoint interval (or end-of-data reached).
"time-limit" specifies a time interval.  This can be specified with item-
count.  If time-limit reached before item-count, then checkpoint taken.

4. skip-limit and retry-limit
These control the behavior when configured skippable or retryable 
exceptions are encountered.  This allows a job step to survive occasional 
or intermittent errors you've configured to skip and retry.
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Status Codes: "Batch Status" and "Exit Status"

Flows and splits ...

Batch Container

Application

"Batch Status"
● STARTING
● STARTED
● STOPPING
● STOPPED
● FAILED
● COMPLETED
● ABANDONED

Container sets 
this for each 
step and the 
job overall

"Exit Status"
● Under the control of the application

If the application does not explicitly set, then the "exit status" ends up being what the 
container sets for the "batch status"
Otherwise, the application can override and set its own exit status

● Container classes: JobContext and StepContext
Two container-supplied classes that provide methods accessible to applications to get 
various context information, and to set context values.  For example:
Job: getJobName(), getProperties(), getBatchStatus(), getExitStatus(), setExitStatus()
Step: getStepName(), getProperties(), getBatchStatus(), getExitStatus(), setExitStatus()

● This is useful in controlling flow of "orchestration"
We're going to look at "orchestration" – the flow of steps within a job – in detail.
Key point here: the JSR-352 specification provides a way to control the flow based on 
the exit status of jobs.  This is very similar to z/OS JCL condition codes.  The Job 
Specification Language (JSL) provides an "On (exit) To (next)" mechanism.  
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Job Step "Flows" and "Splits"

Step partitioning ...

Start

End

Step A

Step B

Step C

Step D

A simple sequential 
processing of steps:

This is what we commonly 
think of as "batch," and 
this may be what you do

Step A

Step B

Step C

Step D

Step E

Step F

Step G

1

2

Start

End

Another 
Flow

1. Flow
From the spec: "A flow defines a sequence of 
execution elements that execute together as a 
unit."

2. Split
From the spec: "A split defines a set of flows that 
execute concurrently. A split may include only 
flow elements as children."
This picture shows two splits, but you may have 
more if you wish

Key Points:
● This is optional; you don't have to utilize this
● These flows and splits are defined in the Job 

Specificaton Language (JSL) file; they are not 
part of the Java code itself.

● The flows and splits for a given job operate 
within the same JVM; it will utilize separate 
threads.  This is not "step partitioning," which 
can parallelize across JVMs.
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Job Step "Partitioning"

JSL section ...

Step A

Step A
Partition 1

Step A
Partition 2

Step A
Partition n

To the next step or 
flow, or to end of job

From the spec: "A partitioned step runs as multiple instances of the same step definition across multiple threads, one partition per 
thread."

Key Points:
● This is optional; you don't have to utilize this
● Not all processing lends itself to effective partitioning.  The data 

may be arranged in such a way that serial processing is better.
However, if applicable, this can be an effective way to shorten 
processing time by parallelizing the processing.

● With IBM Liberty Java Batch, the partitions may run on multiple 
threads in the same server, or on threads across JVMs.

● This does not happen by magic.  The spec: "Each partition needs 
the ability to receive unique parameters to instruct it which data 
on which to operate."  
You must have knowledge of your data layout, and you must code 
your partition step to accept and operate on the data-range 
parameters.

The details of this is beyond the scope of this workshop
It is great technology, but at some point we have to draw a line to keep this workshop 2 days.
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Job Specification Language (JSL)Job Specification Language (JSL)
This defines and controls the execution of the jobThis defines and controls the execution of the job
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The Role of the Job Specification Language (JSL) File

WDT Tool to compose JSL ...

JSR-352 Batch Container

Batch Application

JSR-352 Server Runtime

JSL

The JSL file tells the story about what the batch job is 
comprised of, and how it is to run:

● Number of steps
● Step type (batchlet or chunk)
● Java class files that implement the steps
● Chunk type checkpoint policies
● Splits and flow processing
● Other control information externalized from the application

Syntax is XML; the elements are defined in the JSR-352 
standard specification document
JSL is typically packaged with the batch application, but 
IBM Liberty Java Batch supports separate file pointed to at 
time of submission (called "inline JSL")
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JSL Editor in the WebSphere Developer Tool (WDT) for Eclipse

SleepyBatchlet JSL ...
http://www.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/WP102639Techdoc

There is IBM tooling support for Java Batch 
development.  The Techdoc shown below 
provides details on installing into Eclipse.

Included is a "JSL Editor," which can help 
you design the job and the associated JSL.

The JSR specification document has further 
details on the JSL elements.  Many other 
resources exist for details on the XML.

Generated
Source JSL

Generated
Source JSL

JSL Design
Tool

JSL Design
Tool

Use this to create the JSL 
initially.  If you wish to modify, 
then do so manually, or use 
the JSL Editor.

http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/WP102639
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Real JSL – the JSL Packaged with the SleepyBatchlet Sample Program

Hypothetical two-step job ...

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<job id="sleepy-batchlet" xmlns="http://xmlns.jcp.org/xml/ns/javaee" version="1.0">

<step id="step1">
<batchlet ref="com.ibm.ws.jbatch.sample.sleepybatchlet.SleepyBatchlet" >

            <properties>
                <property name="sleep.time.seconds" value="#{jobParameters['sleep.time.seconds']}" />
            </properties>
        </batchlet>

</step>
</job>

SleepyBatchletSample-1.0.war /WEB-INF
  /classes
    /META-INF
      /batch-jobs
         sleepy-batchlet.xml
    /com/ibm/ws/jbatch/sample/sleepy-batchlet
       SleepyBatchlet.class

1
2

3

4

1. One Step
This sample job has one step, which is the minimum.

2. Step is a batchlet
That one step is defined as a "batchlet"

3. The Java class that implements the job step
The ref= points to the Java class for the batchlet

4. One property is defined
You can pass in the number of seconds to "sleep"
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A Hypothetical Two-Step Job

Hypothetical with conditional next ...

<?xml version="1.0" encoding="UTF-8"?>
<job ... id="MyJob" restartable="true" version="1.0">

<step id="MyStep1" next="MyStep2">
<batchlet ref="com.ibm.test.Step1Batchlet" />

</step>
<step id="MyStep2">

<chunk checkpoint-policy="item" item-count="1000">
<reader ref="com.ibm.test.MyReader" />
<processor ref="com.ibm.test.MyProcessor" />
<writer ref="com.ibm.test.MyWriter" />

</chunk>
</step>

</job>

BatchletBatchlet

ItemReaderItemReader

ItemProcessorItemProcessor

ItemWriterItemWriter

Chunk

Job

Step

Step
In the JSL Editor the job and steps 
would be composed like this

The JSL that gets 
created looks like this:

1

2

3

4

5

6

See speaker notes for notes that correspond 
to the numbered circles on this chart
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Another Hypothetical … Showing Conditional "Next" Processing

Split and flows ...

Prepare
Batchlet

Prepare
Batchlet

Cleanup
Batchlet

Cleanup
Batchlet

Finish
Chunk

Finish
Chunk

Start

End

Fail

If Exit=8If Exit=0

Assumption that Prepare sets the exit 
Status to 0 or 8 depending on how 

finishes, and that the Cleanup batchlet 
always sets an exitStatus of 12.

<?xml version="1.0" encoding="UTF-8"?>
<job  ... id="MyJob" restartable="true" version="1.0">

<step id="Prepare">
<batchlet ref="com.ibm.test.Prepare" />
<next on="0" to="Good-Finish" />
<next on="8" to="Bad-Cleanup" />

</step>
<step id="Bad-Cleanup">

<batchlet ref="com.ibm.test.Cleanup" />
<fail on="12" exit-status="Post-Cleanup"/>

</step>
<step id="Good-Finish">

<chunk>
<reader ref="com.ibm.test.FinalStepReader" />
<processor ref="com.ibm.test.FinalStepProcessor" />
<writer ref="com.ibm.test.FinalStepWriter" />

</chunk>
</step>

</job>
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Yet Another Hypothetical … Split and Two Flows

JSL for this hypothetical ...

BatchletBatchlet

SplitSplit

ChunkChunk

ChunkChunk

ChunkChunk

BatchletBatchlet

Flow Flow
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Same Hypothetical with the Generated JSL

Listeners ...

BatchletBatchlet

SplitSplit

ChunkChunk

ChunkChunk

ChunkChunk

BatchletBatchlet

Flow Flow

<?xml version="1.0" encoding="UTF-8"?>
<job ... id="MyJob" restartable="true" version="1.0">

<step id="Step1" next="MySplit">
<batchlet ref="com.ibm.test.Step1Batchlet" />

</step>
<split id="MySplit" next="AfterSplit">

<flow id="Flow1">
<step id="Flow1Step1" next="Flow1Step2">

<chunk>
<reader ref="com.ibm.test.Flow1Step1Reader" />
<processor ref="com.ibm.test.Flow1Step1Processor" />
<writer ref="com.ibm.test.Flow1Step1Writer" />

</chunk>
</step>
<step id="Flow1Step2">

<chunk>
<reader ref="com.ibm.test.Flow1Step2Reader" />
<processor ref="com.ibm.test.Flow1Step2Processor" />
<writer ref="com.ibm.test.Flow1Step2Writer" />

</chunk>
</step>

</flow>
<flow id="Flow2">

<step id="Flow2Step1">
<batchlet ref="com.ibm.test.Flow2Step1Batchlet" />

</step>
</flow>

</split>
<step id="AfterSplit">

<chunk>
<reader ref="com.ibm.test.AfterSplitReader" />
<processor ref="com.ibm.test.AfterSplitProcessor" />
<writer ref="com.ibm.test.AfterSplitWriter" />

</chunk>
</step>

</job>

Flow 1

Flow 2

After both flows complete

1

2
3

4

5You're not limited to just two 
flows in a split.  And it's possible 

to have splits inside of splits.
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"Listeners" – Job, Step, Chunk, ItemRead, ItemProcess, ItemWrite, Skip, and Retry

Generated JobListener stub ...

"Listeners" are callable interfaces behind which you may implement your own code to get control at various points in 
a job process: start of job, end of job, start of step, end of step, beginning of chunk, end of chunk, etc.

This is what job, step, chunk, read, process 
and write listeners look like in the JSL Editor
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Example: The Job Listener Generate Stub Code

Passing in parameters ...

The batch container will call these interfaces at the 
beginning and the end of the job

You may implement any processing here that you wish.  

Your code gets control, does what it does, and returns

The other listeners 
are similar in design
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Passing Parameters to the Batch Program

Summary ...

<property name="sleep.time.seconds" value="#{jobParameters['sleep.time.seconds']}" />

import javax.batch.api.BatchProperty;
import javax.inject.Inject;

@Inject
@BatchProperty(name = "sleep.time.seconds")
String sleepTimeSecondsProperty;
private int sleepTime_s = 15;

@Override
public String process() throws Exception { 

    if (sleepTimeSecondsProperty != null) {
        sleepTime_s = Integer.parseInt(sleepTimeSecondsProperty);
    }

    int i;
    for (i = 0; i < sleepTime_s && !stopRequested; ++i) {
        log("process", "[" + i + "] sleeping for a second..."); 
        Thread.sleep(1 * 1000);
    }

Step Property 
in JSL

./batchManager submit ... --applicationName=SleepyBatchletSample-1.0 
--jobXMLName=sleepy-batchlet.xml --jobParameter=sleep.time.seconds=99 --wait

Job submission 
command

Default if nothing passed in

The SleepyBatchlet sample provides the 
ability to pass in a job parameter and have it 
injected into the batch program.
The property is the time to "sleep" … which 
controls how long the batchlet runs.
A <property> on the batchlet step in the JSL 
defines the property and opens it to being 
passed in as a job parameter.
The property is then available to the batch 
program.
If a non-null value is passed in, then the value 
passed in overrides the default, and the 
batchlet "sleeps" for the time specified.
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Summary

This is a big topic, and our objective here was to provide an 
understanding of the essential framework
We did not get into actual Java coding, but we did highlight how 
the WDT tool generates the stub classes for you to complete.
The key things to take-away:

● Two programming models: batchlet and chunk
● Job orchestration is accomplished with Job Specification Language (JSL)
● Your job can be simple (one step) or sophisticated (splits and flows)
● You can pass parameters into jobs from job submission

http://www.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/WP102706

A Techdoc to be aware of: "Understanding Java Batch (JSR-352)"

http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/WP102706
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Screen Shots of JSL EditorScreen Shots of JSL Editor
This illustrates how the "split and two flow" example is builtThis illustrates how the "split and two flow" example is built
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A Hypothetical Job We'll Use to Illustrate WDT and JSL Editor

Initial step ...

Start

End

Step
Chunk
Step
Chunk

Step
Chunk
Step
Chunk

Step
Batchlet
Step

Batchlet

SplitSplit

Step
Batchlet
Step

Batchlet

Step
Chunk
Step
Chunk

Flow Flow

1

2

3 4

5

1. Start with a batchlet step
We start with a batchlet step for no reason other than it's relatively easy to 
illustrate.

2. Start a split with two flows
A split may contain only flows, not steps outside of a flow.  So we'll create two 
flows under the split and populate those flows with steps.

3. Flow with two steps, both chunk
For this flow we'll show two steps in the flow.  We'll make them both chunk steps 
for illustration.

4. Flow with one step, which is a batchlet
For the other flow we'll have only one step to show that scenario.  We'll make it a 
batchlet just to show a flow can contain either chunk or batchlets.

5. Finish with a final chunk step
We'll bring the split together with a final chunk step.  After that the job ends.

We're not going to show Java coding.  We're just going to 
show what it looks like to compose a job in the JSL editor, 

and use the generated JSL to explain the elements.
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Starting Out … Creating the Initial Step

Create batchlet ...

The Job was created 
with File → New → 
Other → Batch Job

Then right-mouse 
click, Add → Step

Then right-mouse 
click on the new step 
and Add → Batchlet

The red X's are because the batchlet 
reference is not yet provided
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Creating the Batchlet

Create the split ...

Click on 
"Reference"

Provide package 
and class name

Click "Finish"

Result is an editor with Java framework for a 
batchlet step.  The required interfaces are pre-

populated; you code from there.
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Create the Split

Add flows under split ...

Highlight the Job, then 
click on Add → Split

The split appears in 
sequence after the first step

You can rename created elements here.  
The split is renamed to "Split1" and the 

initial step was renamed to "Step1"
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Add Flows Under the Defined Split

Add steps to the flows ...

Highlight the Split, then 
click on Add → Flow

Here we're showing the 
result after creating and 

renaming two flows

What the source JSL looks 
like at this point.
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Add Steps to the Flows

Add chunks to the flow steps ...

Highlight the Flow, then 
click on Add → Step

Here we're showing the 
result after creating and 

renaming two steps

Next … add a "chunk" under each of those steps
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Add Chunk to the First Step in the Flow

Resolve ItemReader reference ...

Highlight the Step, then 
click on Add → Chunk

Highlight the Chunk, then 
click on Add → Processor

The red X's are because the chunk 
references are not yet provided
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Resolve the References for the ItemReader of the Chunk Step

Generated ItemReader code ...

Click on 
"Reference"

Highlight 
the Reader

Provide package 
and class name

Click "Finish"
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Result: Generated Java for the ItemReader Class that Implements that Reader

Result after creating second chunk step ...

Result is an editor with Java framework for a ItemReader 
class.  The required interfaces are pre-populated; you code 
from there.

Do the same for ItemProcessor and ItemWriter.  Result:

The exact same process is 
followed to create the 

chunk under the second 
step of the flow
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Add Chunk to Second Step in the Flow and Resolve the References

Adding Next  ...

We're now starting to repeat the same steps over and over, so we won't show detail

Step
Chunk
Step
Chunk

Step
Chunk
Step
Chunk

Step
Batchlet
Step

Batchlet

SplitSplit

Step
Batchlet
Step

Batchlet

Step
Chunk
Step
Chunk

Flow Flow
Not yet completed, but 
the process is as we've 
already illustrated: just 
point and click and 
resolving package and 
class references
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Add "Next" References so Flow Through Job Specified in the JSL

The final result  ...

Step
Chunk
Step
Chunk

Step
Chunk
Step
Chunk

Step
Batchlet
Step

Batchlet

SplitSplit

Step
Batchlet
Step

Batchlet

Step
Chunk
Step
Chunk

Flow Flow

1

3

4

2

1. Set "Next" on Step1 to Indicate "Split1"

3. Set "Next" on Flow1Step1 to Indicate "Flow1Step2"

2. Split will go down each defined flow in the split
You do define a "Next" on the Split, but not to the flows.  You define "Next" to indicate where to 
go after the split comes back together.  See #4 below.

4. Set "Next" on split to go to "FinalStep"
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All the Steps, Splits and Flows … and the Generated JSL
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